5.4.1~rc2 montage read-only → plantage vs lecture seule :(

classic Classic list List threaded Threaded
5 messages Options
Serge Smeesters Serge Smeesters
Reply | Threaded
Open this post in threaded view
|

5.4.1~rc2 montage read-only → plantage vs lecture seule :(

Bonjour à tous,


Ce problème est-il connu ?

Dès lors que le montage (unionfs ro, mount bind ro, smb ro, iso, etc.)
est en "read-only" mais que les stats indiquent "w", alors (sous
GNU/Linux ; Windows pas testé), LireOffice se plante plutôt que d'ouvrir
en lecture seule :(

Pour faire le teste :

$ mkdir A B
créer un A/document.odt
faire un # mount -Bo ro A B

Via l'interface graphique, tenter d'ouvrir B/document.odt

LibreOffice se lance, tourne puis se plante :(


Le comportement attendu, celui das versions précédentes de LibreOffice,
c'était que LibreOffice ouvrait en lecture seule le document :)


Ce bug de régression est-il connu ?


Bien à vous,
Serge Smeesters

--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/qa/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Laurent BALLAND-POIRIER Laurent BALLAND-POIRIER
Reply | Threaded
Open this post in threaded view
|

Re: 5.4.1~rc2 montage read-only → plantage vs lecture seule :(

Bonjour,

Sur Ubuntu 16.04 pas de crash avec LibO 5.4.2.2.

Quand j'essaie de l'ouvrir via l'interface, rien ne se fait. Si quand
j'essaie de l'ouvrir, je coche "Lecture seule", le fichier s'ouvre bien.

Avec le master à jour, j'obtiens un message d'erreur "General
input/output error while accessing /home/.../B/doc1.odt." Si je coche en
lecture seule le fichier s'ouvre bien.

Sur OpenSuse 42.3 et LibO 5.3.5.2 le fichier s'ouvre directement en
lecture seule, même si lecture seule n'est pas cochée.

Laurent BP


Le 08/10/2017 à 15:19, Serge Smeesters a écrit :

> Bonjour à tous,
>
>
> Ce problème est-il connu ?
>
> Dès lors que le montage (unionfs ro, mount bind ro, smb ro, iso, etc.)
> est en "read-only" mais que les stats indiquent "w", alors (sous
> GNU/Linux ; Windows pas testé), LireOffice se plante plutôt que
> d'ouvrir en lecture seule :(
>
> Pour faire le teste :
>
> $ mkdir A B
> créer un A/document.odt
> faire un # mount -Bo ro A B
>
> Via l'interface graphique, tenter d'ouvrir B/document.odt
>
> LibreOffice se lance, tourne puis se plante :(
>
>
> Le comportement attendu, celui das versions précédentes de
> LibreOffice, c'était que LibreOffice ouvrait en lecture seule le
> document :)
>
>
> Ce bug de régression est-il connu ?
>
>
> Bien à vous,
> Serge Smeesters
>


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/qa/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Laurent BALLAND-POIRIER Laurent BALLAND-POIRIER
Reply | Threaded
Open this post in threaded view
|

Re: 5.4.1~rc2 montage read-only → plantage vs lecture seule :(

Bonsoir,

J'ai ouvert le rapport :

https://bugs.documentfoundation.org/show_bug.cgi?id=113024

N'hésitez pas à le compléter et à le confirmer.

Laurent BP


Le 08/10/2017 à 15:49, Laurent Balland-Poirier a écrit :

> Bonjour,
>
> Sur Ubuntu 16.04 pas de crash avec LibO 5.4.2.2.
>
> Quand j'essaie de l'ouvrir via l'interface, rien ne se fait. Si quand
> j'essaie de l'ouvrir, je coche "Lecture seule", le fichier s'ouvre bien.
>
> Avec le master à jour, j'obtiens un message d'erreur "General
> input/output error while accessing /home/.../B/doc1.odt." Si je coche
> en lecture seule le fichier s'ouvre bien.
>
> Sur OpenSuse 42.3 et LibO 5.3.5.2 le fichier s'ouvre directement en
> lecture seule, même si lecture seule n'est pas cochée.
>
> Laurent BP
>
>
> Le 08/10/2017 à 15:19, Serge Smeesters a écrit :
>> Bonjour à tous,
>>
>>
>> Ce problème est-il connu ?
>>
>> Dès lors que le montage (unionfs ro, mount bind ro, smb ro, iso,
>> etc.) est en "read-only" mais que les stats indiquent "w", alors
>> (sous GNU/Linux ; Windows pas testé), LireOffice se plante plutôt que
>> d'ouvrir en lecture seule :(
>>
>> Pour faire le teste :
>>
>> $ mkdir A B
>> créer un A/document.odt
>> faire un # mount -Bo ro A B
>>
>> Via l'interface graphique, tenter d'ouvrir B/document.odt
>>
>> LibreOffice se lance, tourne puis se plante :(
>>
>>
>> Le comportement attendu, celui das versions précédentes de
>> LibreOffice, c'était que LibreOffice ouvrait en lecture seule le
>> document :)
>>
>>
>> Ce bug de régression est-il connu ?
>>
>>
>> Bien à vous,
>> Serge Smeesters
>>
>
>


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/qa/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Serge Smeesters Serge Smeesters
Reply | Threaded
Open this post in threaded view
|

5.4.2~rc2 montage read-only → plantage vs lecture seule :(

In reply to this post by Laurent BALLAND-POIRIER
Bonjour à tous,

Merci aux développeurs de prendre ceci très au sérieux.

C'est vraiment un très gros problème vis-à-vis de l'utilisation de système de
sauvegardes (“backup” en anglais).

Bien souvent, l'accès aux dossiers et fichiers sauvegardés est en lecture seule
mais les stat's sur les dossiers et fichiers ne l'informe pas forcément aux
logiciels (LibrOffice).

Je n'avais encore jamais rencontré ce genre de problème.

Le comportement souhaité :
Quelles que puissent être les raisons, si LibreOffice ne sait pas ouvrir en
lecture-écriture (création du verrou .~lock.) alors toujours ouvrir en lecture
seule.

Mais pas planter comme ça ! SVP :/

Je dois probablement m'excuser auprès de vous, de ne pas être moi-même
développeur :/ Et de ne pas avoir énormément de temps... Énormément de travail
administratif, vie de famille, etc. :/ (“Just do it!”)

La seule chose que je peux facilement faire est de partager ici mes constats de
régression...

En l'occurrence, le bogue (“bug”) est-il déjà connu ?, référencé ? suivi ?

Version ici utilisé :

 Version: 5.4.2.2
 Build ID: 1:5.4.2~rc2-0ubuntu0.16.04.1~lo1
 Threads CPU : 3; OS : Linux 4.10; UI Render : par défaut; VCL : gtk2;
 Locale : fr-BE (fr_BE.UTF-8); Calc: group

Via ppa:libreoffice/ppa sous GNU/Linux Mint 18.2 MATE 64 bits.

Un tout Grand Merci aux développeurs !

Bonne journée,
Serge Smeesters
http://www.gnucomputer.be/ 
http://www.spaceeman.be/ 


Le 8 octobre 2017 à 15:49, Laurent Balland-Poirier
<[hidden email]> a écrit :

> Bonjour,
> Sur Ubuntu 16.04 pas de crash avec LibO 5.4.2.2.
> Quand j'essaie de l'ouvrir via l'interface, rien ne se fait. Si quand
> j'essaie de l'ouvrir, je coche "Lecture seule", le fichier s'ouvre bien.
> Avec le master à jour, j'obtiens un message d'erreur "General
> input/output error while accessing /home/.../B/doc1.odt." Si je coche en
> lecture seule le fichier s'ouvre bien.
> Sur OpenSuse 42.3 et LibO 5.3.5.2 le fichier s'ouvre directement en
> lecture seule, même si lecture seule n'est pas cochée.
> Laurent BP

> Le 08/10/2017 à 15:19, Serge Smeesters a écrit :
>> Bonjour à tous,
>> Ce problème est-il connu ?
>> Dès lors que le montage (unionfs ro, mount bind ro, smb ro, iso, etc.)
>> est en "read-only" mais que les stats indiquent "w", alors (sous
>> GNU/Linux ; Windows pas testé), LireOffice se plante plutôt que
>> d'ouvrir en lecture seule :(
>> Pour faire le teste :
>> $ mkdir A B
>> créer un A/document.odt
>> faire un # mount -Bo ro A B
>> Via l'interface graphique, tenter d'ouvrir B/document.odt
>> LibreOffice se lance, tourne puis se plante :(
>> Le comportement attendu, celui das versions précédentes de
>> LibreOffice, c'était que LibreOffice ouvrait en lecture seule le
>> document :)
>> Ce bug de régression est-il connu ?
>> Bien à vous,
>> Serge Smeesters

--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/qa/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Serge Smeesters Serge Smeesters
Reply | Threaded
Open this post in threaded view
|

Re: 5.4.2~rc2 montage read-only → plantage vs lecture seule :(

[...]
> En l'occurrence, le bogue (“bug”) est-il déjà connu ?, référencé ? suivi ?
 
Oups, j'avais pas vu le dernier message :
 
... rapport :

https://bugs.documentfoundation.org/show_bug.cgi?id=113024

N'hésitez pas à le compléter et à le confirmer.

--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/qa/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés