Bringing LibreOffice modifications for EPM upstream?

classic Classic list List threaded Threaded
1 message Options
Michael Weghorn Michael Weghorn
Reply | Threaded
Open this post in threaded view
|

Bringing LibreOffice modifications for EPM upstream?

Hi,

the LibreOffice build uses EPM ("ESP Package Manager"), e.g. to generate
deb packages when the build option "--with-package-format=deb" is given.

I realized that LibreOffice uses and old version of EPM and applies a
patch that does quite a few modifications [1].

As I experienced a build failure when using unpatched upstream versions
of EPM (i.e. no build option "--with-epm=internal" given), I was
wondering whether it wouldn't be a good idea to work on integrating
(still relevant) LibreOffice modifications upstream? [2]

I would be willing to at least look at those things I come across while
trying to build the Debian packages with upstream EPM.

What do you think?
What would be needed to make sure that proper attribution for the
modifications is made? (E.g. is it enough to mention something like
"This commit is based on a patch of the the LibreOffice community to an
older version of EPM." or something like that?)


Best regards,
  Michael

[1] Patch: file "./external/epm/epm-3.7.patch" in the "core" git repo
[2] upstream GitHub page: https://github.com/michaelrsweet/epm
_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice