CALC et macros

classic Classic list List threaded Threaded
2 messages Options
demande_aide_fr demande_aide_fr
Reply | Threaded
Open this post in threaded view
|

CALC et macros

Bonjour

Voici une nouvelle question envoyée à l'aide du formulaire de demande d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
Si vous répondez, merci de penser à utiliser la fonction "répondre à tous" de votre logiciel de courrier électronique de façon que le demandeur reçoive une copie de votre réponse.


Email:: [hidden email]
Sujet:: CALC et macros
OS:: Windows 8 ou 8.1
Version:: 5.3.x
Question:: Bonjour,
CALC et question de novice :
J'ai réalisé une macro (par enregistrement) pour mise en forme après chargement d'un fichier .csv, mais ...

- une fois le fichier affiché, lorsque j'utilise Outils/Macros/Utiliser la macro, j'ai d'abord un message d'erreur "LO nécessite un environnement ... etc, veuillez installer un JRE et redémarrer"
  j'appuie sur OK : au bout de 3 secondes la fenêtre sélecteur de macro s'ouvre et je peux utiliser la mienne, ou d'autres à chaque demande ultérieure tant que la feuille n'est pas refermée...

Je ne vois pas ce que vient faire l'obligation d'un JRE là dedans étant donné que des macros "natives" sont visible et que ma macro, créée donc par LO, fonctionne bien.

Donc comment éviter ce message parasite.

D'autre part, toujours dans cette macro j'ai inséré une fonction, à partir de
Insertion/Fonction... SI qui donne en clair dans la cellule A2 par exemple :
=SI(B2=B1;"*";"") Les cellules colonne 2 sont des chaines alphanumériques de longueur fixe.
Or au lancement de la macro j'ai un message d'erreur : "LO Calc a détecté une erreur ... " et me propose de remplacer par =SI(B1;"*";"")
-je réponds Non et ma formule fonctionne ...

Toute aide sera bienvenue ;-)

Merci


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Gilles-3 Gilles-3
Reply | Threaded
Open this post in threaded view
|

Re: CALC et macros

Bonjour

Désolé je ne réponds pas à tes questions mais, pour importer les csv en
les formatant, il existe cette extension :
https://extensions.libreoffice.org/extensions/import-csv

Cordialement
Gilles

Le 12/01/2018 à 18:03, [hidden email] a écrit :

> Bonjour
>
> Voici une nouvelle question envoyée à l'aide du formulaire de demande d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
> Si vous répondez, merci de penser à utiliser la fonction "répondre à tous" de votre logiciel de courrier électronique de façon que le demandeur reçoive une copie de votre réponse.
>
>
> Email:: [hidden email]
> Sujet:: CALC et macros
> OS:: Windows 8 ou 8.1
> Version:: 5.3.x
> Question:: Bonjour,
> CALC et question de novice :
> J'ai réalisé une macro (par enregistrement) pour mise en forme après chargement d'un fichier .csv, mais ...
>
> - une fois le fichier affiché, lorsque j'utilise Outils/Macros/Utiliser la macro, j'ai d'abord un message d'erreur "LO nécessite un environnement ... etc, veuillez installer un JRE et redémarrer"
>    j'appuie sur OK : au bout de 3 secondes la fenêtre sélecteur de macro s'ouvre et je peux utiliser la mienne, ou d'autres à chaque demande ultérieure tant que la feuille n'est pas refermée...
>
> Je ne vois pas ce que vient faire l'obligation d'un JRE là dedans étant donné que des macros "natives" sont visible et que ma macro, créée donc par LO, fonctionne bien.
>
> Donc comment éviter ce message parasite.
>
> D'autre part, toujours dans cette macro j'ai inséré une fonction, à partir de
> Insertion/Fonction... SI qui donne en clair dans la cellule A2 par exemple :
> =SI(B2=B1;"*";"") Les cellules colonne 2 sont des chaines alphanumériques de longueur fixe.
> Or au lancement de la macro j'ai un message d'erreur : "LO Calc a détecté une erreur ... " et me propose de remplacer par =SI(B1;"*";"")
> -je réponds Non et ma formule fonctionne ...
>
> Toute aide sera bienvenue ;-)
>
> Merci


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés