Calc: Fehler in SVERWEIS()?

classic Classic list List threaded Threaded
11 messages Options
Boris kirkorowicz-2 Boris kirkorowicz-2
Reply | Threaded
Open this post in threaded view
|

Calc: Fehler in SVERWEIS()?

Hallo,
in der ersten von zwei Tabellen desselben Dokuments steht bspw:

          A       B
1 Text 1   Wert 1
2 Text (2) Wert 2

In der zweiten Tabelle steht:

          A       B
1 =Tabelle1.A1 =SVERWEIS(A1;Tabelle1.A1:B2;2;0)
2 =Tabelle1.A2 =SVERWEIS(A2;Tabelle1.A2:B3;2;0)



In Tabelle2 wird angezeigt:

           A       B
1 Text 1 Wert 1
1 Text (2) #NV


Als einzigen Unterschied sehe ich, dass der Text in A2 runde Klammern
enthält. Warum erzeugt das ein #NV bei SVERWEIS()? Ist das ein Fehler,
Einstellungssache oder ein Verständnisproblem?



--
Mit freundlichem Gruß                                 Best regards
                            Boris Kirkorowicz

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
h.leininger h.leininger
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Fehler in SVERWEIS()?

Hallo,
bei mir tritt es nicht auf. Ich sehe in der zweiten Tabelle:

Text 1      Wert 1
Text (2)    Wert 2

Windows 10, LO 5.3

Helmut
Am 16.02.2017 um 17:38 schrieb Boris Kirkorowicz:

> Hallo,
> in der ersten von zwei Tabellen desselben Dokuments steht bspw:
>
>       A            B
> 1    Text 1      Wert 1
> 2    Text (2)    Wert 2
>
> In der zweiten Tabelle steht:
>
>       A            B
> 1    =Tabelle1.A1    =SVERWEIS(A1;Tabelle1.A1:B2;2;0)
> 2    =Tabelle1.A2    =SVERWEIS(A2;Tabelle1.A2:B3;2;0)
>
>
>
> In Tabelle2 wird angezeigt:
>
>        A           B
> 1    Text 1        Wert 1
> 1    Text (2)    #NV
>
>
> Als einzigen Unterschied sehe ich, dass der Text in A2 runde Klammern
> enthält. Warum erzeugt das ein #NV bei SVERWEIS()? Ist das ein Fehler,
> Einstellungssache oder ein Verständnisproblem?
>
>
>


---
Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.
https://www.avast.com/antivirus



--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Helmut
Boris kirkorowicz-2 Boris kirkorowicz-2
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Fehler in SVERWEIS()?

Hallo,

Am 16.02.2017 um 17:57 schrieb Helmut Leininger:
> Hallo,
> bei mir tritt es nicht auf. Ich sehe in der zweiten Tabelle:
>
> Text 1      Wert 1
> Text (2)    Wert 2
>
> Windows 10, LO 5.3

ich nutze LO 5.2.3.3 unter Suse Linux (Leap 42.1).
Welche Version ist in Leap 42.1 enthalten, und tritt es da auch nicht
mehr auf?



--
Mit freundlichem Gruß                                 Best regards
                            Boris Kirkorowicz

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Boris kirkorowicz-2 Boris kirkorowicz-2
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Fehler in SVERWEIS()?

In reply to this post by h.leininger
Hallo,

Am 16.02.2017 um 17:57 schrieb Helmut Leininger:
> bei mir tritt es nicht auf. Ich sehe in der zweiten Tabelle:
>
> Text 1      Wert 1
> Text (2)    Wert 2
>
> Windows 10, LO 5.3

Korrektur:
ich nutze LO 5.2.3.3 unter Suse Linux (Leap 42.1).
Welche Version ist in Leap 42.2 enthalten, und tritt es da auf?

--
Mit freundlichem Gruß                                 Best regards
                            Boris Kirkorowicz

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
h.leininger h.leininger
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Fehler in SVERWEIS()?

Kannst du die Beispieldatei irgendwo zur Verfügung stellen ?

Am 16.02.2017 um 18:15 schrieb Boris Kirkorowicz:

> Hallo,
>
> Am 16.02.2017 um 17:57 schrieb Helmut Leininger:
>> bei mir tritt es nicht auf. Ich sehe in der zweiten Tabelle:
>>
>> Text 1      Wert 1
>> Text (2)    Wert 2
>>
>> Windows 10, LO 5.3
>
> Korrektur:
> ich nutze LO 5.2.3.3 unter Suse Linux (Leap 42.1).
> Welche Version ist in Leap 42.2 enthalten, und tritt es da auf?
>


---
Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.
https://www.avast.com/antivirus



--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Helmut
Wolfgang Jäth Wolfgang Jäth
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Fehler in SVERWEIS()?

In reply to this post by Boris kirkorowicz-2
Am 16.02.2017 um 17:38 schrieb Boris Kirkorowicz:

> Hallo,
> in der ersten von zwei Tabellen desselben Dokuments steht bspw:
>
>  A       B
> 1 Text 1   Wert 1
> 2 Text (2) Wert 2
>
> In der zweiten Tabelle steht:
>
>  A       B
> 1 =Tabelle1.A1 =SVERWEIS(A1;Tabelle1.A1:B2;2;0)
> 2 =Tabelle1.A2 =SVERWEIS(A2;Tabelle1.A2:B3;2;0)
>
>
>
> In Tabelle2 wird angezeigt:
>
>   A       B
> 1 Text 1 Wert 1
> 1 Text (2) #NV
>
>
> Als einzigen Unterschied sehe ich, dass der Text in A2 runde Klammern
> enthält. Warum erzeugt das ein #NV bei SVERWEIS()? Ist das ein Fehler,
> Einstellungssache oder ein Verständnisproblem?

Nein; ja; möglicherweise.

SVERWEIS unterstützt defaultmäßig reguläre Ausdrücke; in dem o. a.
Beispiel betrifft das eben genau die runden Klammern. Bei RegEx werden
damit Rückwärtsverweise spezifiziert (aber es würde jetzt und hier zu
weit führen, Die Funktion von Rückwärtsverweisen zu erklären).

Das Problem dabei ist, dass du im *Suchpattern* die Klammern 'maskieren'
d. h. ihnen ein '\'-Zeichen voranstellen müsstest; *gefunden* würde dann
aber nur das *unmaskierte* Pattern.

Du kannst allerdings diese RegEx-Funktion über "Extras => Einstellungen
=> Calc => Berechnen => [_] Reguläre Ausdrücke in Formeln ermöglichen"
abschalten.

Oder Du manipulierst das Suchpattern entsprechend, indem Du in Zelle A2
statt direkt auf "=Tabelle1.A2" zu verweisen einen passend adaptierten
String anbietest:

| =WECHSELN(WECHSELN(Tabelle1.A2;"(";"\(");")";"\)")

Allerdings musst Du in dem Fall *alle* evtl. vorkommenden
RegEx-spezifischen Zeichen und Ausdrücke analog ausmaskieren.

BTW solltest Du die Zielmatrix grundsätzlich mit absoluten Adressen
angeben, also "Tabelle1.$A$1:$B$2" o. ä., dann kann so was wie der in
Zelle B2 sichtbare Versatz nicht passieren. Übrigens: Mit SHIFT-F4
kannst Du zwischen relativen, teilabsoluten und absoluten Adressen hin
und her toggeln.

Wolfgang
--

---
Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.
https://www.avast.com/antivirus


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Werner Tietz Werner Tietz
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Fehler in SVERWEIS()?

In reply to this post by Boris kirkorowicz-2
Hallo Boris
(Entschuldige die PM - hier nochmal an die Liste)



Am 16.02.2017 um 17:38 schrieb Boris Kirkorowicz:

> Hallo,
> in der ersten von zwei Tabellen desselben Dokuments steht bspw:
>
>       A            B
> 1    Text 1      Wert 1
> 2    Text (2)    Wert 2
>
> In der zweiten Tabelle steht:
>
>       A            B
> 1    =Tabelle1.A1    =SVERWEIS(A1;Tabelle1.A1:B2;2;0)
> 2    =Tabelle1.A2    =SVERWEIS(A2;Tabelle1.A2:B3;2;0)
>
>
>
> In Tabelle2 wird angezeigt:
>
>        A           B
> 1    Text 1        Wert 1
> 1    Text (2)    #NV
>
>
> Als einzigen Unterschied sehe ich, dass der Text in A2 runde Klammern
> enthält. Warum erzeugt das ein #NV bei SVERWEIS()? Ist das ein Fehler,
> Einstellungssache oder ein Verständnisproblem?


Einstellungssache: deaktiviere
→Extras→Optionen→Calc→Berechnen→→[]reguläre Ausdrücke in Formeln

Gruß Werner


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Alois Klotz Alois Klotz
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Fehler in SVERWEIS()?

In reply to this post by Boris kirkorowicz-2
Hallo,
ich kann dieses Verhalten mit Version: 5.2.5.1 bestätigen.
Es liegt meiner Meinung nach an den Klammern: runde und eckige machen
das Problem, geschwungene wären ok...
MfG Alois

Boris Kirkorowicz schrieb am 16.02.2017 um 17:38:

> Hallo,
> in der ersten von zwei Tabellen desselben Dokuments steht bspw:
>
>       A            B
> 1    Text 1      Wert 1
> 2    Text (2)    Wert 2
>
> In der zweiten Tabelle steht:
>
>       A            B
> 1    =Tabelle1.A1    =SVERWEIS(A1;Tabelle1.A1:B2;2;0)
> 2    =Tabelle1.A2    =SVERWEIS(A2;Tabelle1.A2:B3;2;0)
>
>
>
> In Tabelle2 wird angezeigt:
>
>        A           B
> 1    Text 1        Wert 1
> 1    Text (2)    #NV
>
>
> Als einzigen Unterschied sehe ich, dass der Text in A2 runde Klammern
> enthält. Warum erzeugt das ein #NV bei SVERWEIS()? Ist das ein Fehler,
> Einstellungssache oder ein Verständnisproblem?
>
>
>


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Boris kirkorowicz-2 Boris kirkorowicz-2
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Fehler in SVERWEIS()?

In reply to this post by h.leininger
Hallo,

Am 16.02.2017 um 18:17 schrieb Helmut Leininger:
> Kannst du die Beispieldatei irgendwo zur Verfügung stellen ?

klar kann ich das, ist ja in einer halben Minute getippt:
http://www.kirk.de/files/calc-SVERWEIS.ods



--
Mit freundlichem Gruß                                 Best regards
                            Boris Kirkorowicz

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Boris kirkorowicz-2 Boris kirkorowicz-2
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Fehler in SVERWEIS()?

In reply to this post by Werner Tietz
Hallo,

Am 16.02.2017 um 18:37 schrieb Werner Tietz:
> Einstellungssache: deaktiviere
> →Extras→Optionen→Calc→Berechnen→→[]reguläre Ausdrücke in Formeln

tatsächlich: Danke.

Welche der beiden alternativen Optionen sollte man bevorzugen? Ist die
Excel-Kompatibilität im Büroalltag wichtig, oder betrifft das nur eher
hochwissenschaftliche Ausnahmefälle oder so was in der Art? Oder
kann/sollte man Platzhalter (was ist das überhaupt?) getrost
vernachlässigen?


--
Mit freundlichem Gruß                                 Best regards
                            Boris Kirkorowicz

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Werner Tietz Werner Tietz
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Fehler in SVERWEIS()?

Hallo Boris

Am 16.02.2017 um 20:59 schrieb Boris Kirkorowicz:

> Hallo,
>
> Am 16.02.2017 um 18:37 schrieb Werner Tietz:
>> Einstellungssache: deaktiviere
>> →Extras→Optionen→Calc→Berechnen→→[]reguläre Ausdrücke in Formeln
>
> tatsächlich: Danke.
>
> Welche der beiden alternativen Optionen sollte man bevorzugen? Ist die
> Excel-Kompatibilität im Büroalltag wichtig, oder betrifft das nur eher
> hochwissenschaftliche Ausnahmefälle oder so was in der Art? Oder
> kann/sollte man Platzhalter (was ist das überhaupt?) getrost
> vernachlässigen?
>

Das hängt doch vom Kontext ab in dem die Dokumente genutzt werden…

…privat|Firma, Austausch mit Excelleuten?, etc.

Das musst du schon selber entscheiden.

Gruß Werner



--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert