Quantcast

Extension-Update-Fehler

classic Classic list List threaded Threaded
19 messages Options
Franklin Schiftan Franklin Schiftan
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Extension-Update-Fehler

Hallo miteinander,

ich stellte gerade unter LibO Version: 5.3.2.2
Build-ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
CPU-Threads: 8; BS-Version: Windows 6.1; UI-Render: Standard;
Layout-Engine: neu;
Gebietsschema: de-DE (de_DE); Calc: group

beim Versuch Extensions upzudaten folgendes fest (wobei diese Fehler
vermutlich auch völlig unabhängig von der LibO-Version in anderen
Versionen des Programmes so auftauchen würden):

1.) DateTime2.oxt:

Ein allgemeiner Internetehler trat auf.   [sic: ohne 'f' ! ]

http://www.re-solutions.de/ooo/extensions/DateTime2.update.xml
existiert nicht.

Das ist bedauerlich, dass hier offensichtlich die in der Extension
vermerkte Quell-Seite für ein Update nicht mehr existiert, zumal die
dann jetzt unter Github gefundene Version 2.0.4 wunderbar
funktioniert. Ich frage mich allerdings, wodurch der Hinweis, dass
es ein Update für diese Extension gibt, dann ausgelöst wurde (als
der Update-Hinweis kam, war noch Version 2.0.3 installiert, aber
wenn die Update-Quelle mit der URL so gar nicht mehr existiert...).

Das fehlende 'f' in der ersten Meldung kann sicher noch jemand
ergänzen ...


2.) HistoryMaster:

Es ist ein Fehler aufgetreten:
Extra content at the end of the document
Line: 299
Column: 1845

Keine Ahnung, welches 'document' hier gemeint ist und was ich tun
könnte, um dieses Problem zu beheben.


3.) Suchen&Ersetzen-Alternative für Writer:

Es ist ein Fehler aufgetreten:
Unbekannter Fehler.

Und hier weiß man natürlich noch weniger, wo man ansetzen könnte,
oder hat jemand Ideen?


--
 ..... und tschüss

               Franklin

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

dieterp dieterp
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

Hallo Franklin,

zu 3) Suchen und Ersetzen-Alternative:

Schau mal, ob du die aktuellste Version hast (1.4.2). Die steht nämlich
auf der Homepage leider nicht unter "Current Release" sondern unter "All
Releases" und zwar ganz am Ende. Damit funktioniert es.

Viele Grüße

Dieter


Am 07.04.2017 um 10:37 schrieb Franklin Schiftan:

> Hallo miteinander,
>
> ich stellte gerade unter LibO Version: 5.3.2.2
> Build-ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
> CPU-Threads: 8; BS-Version: Windows 6.1; UI-Render: Standard;
> Layout-Engine: neu;
> Gebietsschema: de-DE (de_DE); Calc: group
>
> beim Versuch Extensions upzudaten folgendes fest (wobei diese Fehler
> vermutlich auch völlig unabhängig von der LibO-Version in anderen
> Versionen des Programmes so auftauchen würden):
>
> 1.) DateTime2.oxt:
>
> Ein allgemeiner Internetehler trat auf.   [sic: ohne 'f' ! ]
>
> http://www.re-solutions.de/ooo/extensions/DateTime2.update.xml
> existiert nicht.
>
> Das ist bedauerlich, dass hier offensichtlich die in der Extension
> vermerkte Quell-Seite für ein Update nicht mehr existiert, zumal die
> dann jetzt unter Github gefundene Version 2.0.4 wunderbar
> funktioniert. Ich frage mich allerdings, wodurch der Hinweis, dass
> es ein Update für diese Extension gibt, dann ausgelöst wurde (als
> der Update-Hinweis kam, war noch Version 2.0.3 installiert, aber
> wenn die Update-Quelle mit der URL so gar nicht mehr existiert...).
>
> Das fehlende 'f' in der ersten Meldung kann sicher noch jemand
> ergänzen ...
>
>
> 2.) HistoryMaster:
>
> Es ist ein Fehler aufgetreten:
> Extra content at the end of the document
> Line: 299
> Column: 1845
>
> Keine Ahnung, welches 'document' hier gemeint ist und was ich tun
> könnte, um dieses Problem zu beheben.
>
>
> 3.) Suchen&Ersetzen-Alternative für Writer:
>
> Es ist ein Fehler aufgetreten:
> Unbekannter Fehler.
>
> Und hier weiß man natürlich noch weniger, wo man ansetzen könnte,
> oder hat jemand Ideen?
>
>


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Franklin Schiftan Franklin Schiftan
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

Hallo dgp-mail,

am 07.04.2017 um 11:20 Uhr schrieb dgp-mail <[hidden email]>:

> Hallo Franklin,
>
> zu 3) Suchen und Ersetzen-Alternative:
>
> Schau mal, ob du die aktuellste Version hast (1.4.2).

Ja, die 1.4.2 ist hier installiert.

> Die steht nämlich auf der Homepage leider nicht unter "Current
> Release" sondern unter "All Releases" und zwar ganz am Ende.
> Damit funktioniert es.

Hmm, ist lediglich beim ersten 'Auf Updates prüfen' keine
Fehlermeldung für diese Extension zu sehen. Sofern ich den Button
aber ein weiteres Mal klicke, steht die besagte Meldung nach
Einschalten von 'Zeige alle Updates' wieder da.

> Dieter

--
 ..... und tschüss

               Franklin

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

dgp-mail dgp-mail
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

Hallo Franklin,

Ich hatte vor einiger Zeit auch die Fehlermeldung und hatte die
Extension deinstalliert. Nach deiner Mail heute habe ich dann nochmal
nachgeschaut, Version 1.4.2 entdeckt, heruntergeladen, installiert -
funktioniert (LO 5.3.2.2 (x64) mit Win 10).

Dieter


Am 07.04.2017 um 11:27 schrieb Franklin Schiftan:

> Hallo dgp-mail,
>
> am 07.04.2017 um 11:20 Uhr schrieb dgp-mail <[hidden email]>:
>
>> Hallo Franklin,
>>
>> zu 3) Suchen und Ersetzen-Alternative:
>>
>> Schau mal, ob du die aktuellste Version hast (1.4.2).
> Ja, die 1.4.2 ist hier installiert.
>
>> Die steht nämlich auf der Homepage leider nicht unter "Current
>> Release" sondern unter "All Releases" und zwar ganz am Ende.
>> Damit funktioniert es.
> Hmm, ist lediglich beim ersten 'Auf Updates prüfen' keine
> Fehlermeldung für diese Extension zu sehen. Sofern ich den Button
> aber ein weiteres Mal klicke, steht die besagte Meldung nach
> Einschalten von 'Zeige alle Updates' wieder da.
>
>> Dieter


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Thomas Krumbein-3 Thomas Krumbein-3
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

In reply to this post by Franklin Schiftan
Hey Franklin,

Ich kann Dir nicht genau sagen, was bei deinen Extensions schiefläuft -
aber etwas ist mir auch aufgefallen:

Ab LibO 5.3.x muss das Quellcode Programm korrekt sein ;) Jeder kleine
Fehler in einem (Basic-)Makro Programm führt nun zum Abbruch oder
Fehlermeldung.

Das war bisher so nicht der Fall. Hier war OO(LO relativ "tollerant"

Beispiel: eine vergessene schliessende Klammer in einem Ausdruck wie :

v = lcase(trim(sString)

wurde bisher problemlos akzeptiert - ab 5.3. nicht mehr. Das heisst,
viele bisherigen Makros funktionieren nicht mehr... bzw. müssen zunächst
nachgearbeitet werden.

Ich sehe das aber nicht als Fehler von LO, sondern eher der
Vorgänger-Versionen. Es wurde also eine Schwachstelle beseitigt - auch
auf die Gefahr hin, dass nun einiges nicht mehr funktioniert.

Hier bleibt eigentlich nur: Kontaktiere die Autoren der Extension und
informiere sie.


Viele Grüße

Thomas


Am 07.04.2017 um 10:37 schrieb Franklin Schiftan:

> Hallo miteinander,
>
> ich stellte gerade unter LibO Version: 5.3.2.2
> Build-ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
> CPU-Threads: 8; BS-Version: Windows 6.1; UI-Render: Standard;
> Layout-Engine: neu;
> Gebietsschema: de-DE (de_DE); Calc: group
>
> beim Versuch Extensions upzudaten folgendes fest (wobei diese Fehler
> vermutlich auch völlig unabhängig von der LibO-Version in anderen
> Versionen des Programmes so auftauchen würden):
>
> 1.) DateTime2.oxt:
>
> Ein allgemeiner Internetehler trat auf.   [sic: ohne 'f' ! ]
>
> http://www.re-solutions.de/ooo/extensions/DateTime2.update.xml
> existiert nicht.
>
> Das ist bedauerlich, dass hier offensichtlich die in der Extension
> vermerkte Quell-Seite für ein Update nicht mehr existiert, zumal die
> dann jetzt unter Github gefundene Version 2.0.4 wunderbar
> funktioniert. Ich frage mich allerdings, wodurch der Hinweis, dass
> es ein Update für diese Extension gibt, dann ausgelöst wurde (als
> der Update-Hinweis kam, war noch Version 2.0.3 installiert, aber
> wenn die Update-Quelle mit der URL so gar nicht mehr existiert...).
>
> Das fehlende 'f' in der ersten Meldung kann sicher noch jemand
> ergänzen ...
>
>
> 2.) HistoryMaster:
>
> Es ist ein Fehler aufgetreten:
> Extra content at the end of the document
> Line: 299
> Column: 1845
>
> Keine Ahnung, welches 'document' hier gemeint ist und was ich tun
> könnte, um dieses Problem zu beheben.
>
>
> 3.) Suchen&Ersetzen-Alternative für Writer:
>
> Es ist ein Fehler aufgetreten:
> Unbekannter Fehler.
>
> Und hier weiß man natürlich noch weniger, wo man ansetzen könnte,
> oder hat jemand Ideen?
>
>


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

dieterp dieterp
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

In reply to this post by Franklin Schiftan
Hallo Franklin,

Ich hatte vor einiger Zeit auch die Fehlermeldung und hatte die
Extension deinstalliert. Nach deiner Mail heute habe ich dann nochmal
nachgeschaut, Version 1.4.2 entdeckt, heruntergeladen, installiert -
funktioniert (LO 5.3.2.2 (x64) mit Win 10).

Dieter


Am 07.04.2017 um 11:27 schrieb Franklin Schiftan:

> Hallo dgp-mail,
>
> am 07.04.2017 um 11:20 Uhr schrieb dgp-mail <[hidden email]>:
>
>> Hallo Franklin,
>>
>> zu 3) Suchen und Ersetzen-Alternative:
>>
>> Schau mal, ob du die aktuellste Version hast (1.4.2).
> Ja, die 1.4.2 ist hier installiert.
>
>> Die steht nämlich auf der Homepage leider nicht unter "Current
>> Release" sondern unter "All Releases" und zwar ganz am Ende.
>> Damit funktioniert es.
> Hmm, ist lediglich beim ersten 'Auf Updates prüfen' keine
> Fehlermeldung für diese Extension zu sehen. Sofern ich den Button
> aber ein weiteres Mal klicke, steht die besagte Meldung nach
> Einschalten von 'Zeige alle Updates' wieder da.
>
>> Dieter


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Franklin Schiftan Franklin Schiftan
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

In reply to this post by Thomas Krumbein-3
Hallo Thomas,

am 07.04.2017 um 11:36 Uhr schrieb Thomas Krumbein
<[hidden email]>:

> Hey Franklin,
>
> Ich kann Dir nicht genau sagen, was bei deinen Extensions
> schiefläuft - aber etwas ist mir auch aufgefallen:
>
> Ab LibO 5.3.x muss das Quellcode Programm korrekt sein ;) Jeder
> kleine Fehler in einem (Basic-)Makro Programm führt nun zum
> Abbruch oder Fehlermeldung.
>
> Das war bisher so nicht der Fall. Hier war OO(LO relativ
> "tollerant"
>
> Beispiel: eine vergessene schliessende Klammer in einem Ausdruck
> wie :
>
> v = lcase(trim(sString)
>
> wurde bisher problemlos akzeptiert - ab 5.3. nicht mehr. Das
> heisst, viele bisherigen Makros funktionieren nicht mehr... bzw.
> müssen zunächst nachgearbeitet werden.

Danke für die Info ...

> Ich sehe das aber nicht als Fehler von LO,

Nun ja, zumindest die erste Meldung
'Ein allgemeiner Internetehler trat auf.'   [sic: ohne 'f' ! ]
ist aber vermutlich schon in LO (falsch) kodiert bzw. übersetzt, oder?

> sondern eher der Vorgänger-Versionen. Es wurde also eine
> Schwachstelle beseitigt - auch auf die Gefahr hin, dass nun
> einiges nicht mehr funktioniert.
>
> Hier bleibt eigentlich nur: Kontaktiere die Autoren der Extension
> und informiere sie.

Solange die Extensions ansonsten noch wie gewohnt funktionieren,
machen mir die Fehler bei der Updateprüfung eigentlich nichts aus... ;-)

> Thomas

--
 ..... und tschüss

               Franklin

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Franklin Schiftan Franklin Schiftan
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

In reply to this post by dieterp
Hallo dgp-mail,

am 07.04.2017 um 11:37 Uhr schrieb dgp-mail <[hidden email]>:

> Hallo Franklin,
>
> Ich hatte vor einiger Zeit auch die Fehlermeldung und hatte die
> Extension deinstalliert. Nach deiner Mail heute habe ich dann nochmal
> nachgeschaut, Version 1.4.2 entdeckt, heruntergeladen, installiert -
> funktioniert (LO 5.3.2.2 (x64) mit Win 10).

Wie gesagt, diese Version ist hier bereits ebenfalls installiert und
soweit ich sie brauche, funktioniert sie ja auch. Lediglich bei
mehrfacher Updateprüfung kann man diese Fehlermeldung entdecken.

> Dieter

--
 ..... und tschüss

               Franklin

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Gerhard Weydt Gerhard Weydt
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

In reply to this post by Thomas Krumbein-3
Hallo zusammen,

der Grund für solche Fehler ist, dass eine Prüfung auf fehlende rechte
Klammern im Basic-Code in Rel. 5.3 aktiviert wurde. Die ist in einer
späteren Version von 5.3 inzwischen wieder stillgelegt oder verbessert
worden (Bug 106529). Man hat die Ersteller von Extensions informiert,
und so, wie ich es mitgekriegt habe, haben SIe genauso wie ich schnell
eine Version ihrer Extension mit ergänzten Klammern geliefert.
Dummerweise hat die Extensions-Website, die wohl technisch umgestellt
wurde, ein Problem mit der Ergänzung einer neuen Version, so dass die
neueste nicht oben, sondern unten angelegt wird und somit nicht als
neueste angezeigt wird. Der Dienstleister soll an der Korrektur
arbeiten, aber bisher ist die Situation unverändert.

Gerhard

Am 07.04.2017 um 11:36 schrieb Thomas Krumbein:

> Hey Franklin,
>
> Ich kann Dir nicht genau sagen, was bei deinen Extensions schiefläuft
> - aber etwas ist mir auch aufgefallen:
>
> Ab LibO 5.3.x muss das Quellcode Programm korrekt sein ;) Jeder kleine
> Fehler in einem (Basic-)Makro Programm führt nun zum Abbruch oder
> Fehlermeldung.
>
> Das war bisher so nicht der Fall. Hier war OO(LO relativ "tollerant"
>
> Beispiel: eine vergessene schliessende Klammer in einem Ausdruck wie :
>
> v = lcase(trim(sString)
>
> wurde bisher problemlos akzeptiert - ab 5.3. nicht mehr. Das heisst,
> viele bisherigen Makros funktionieren nicht mehr... bzw. müssen
> zunächst nachgearbeitet werden.
>
> Ich sehe das aber nicht als Fehler von LO, sondern eher der
> Vorgänger-Versionen. Es wurde also eine Schwachstelle beseitigt - auch
> auf die Gefahr hin, dass nun einiges nicht mehr funktioniert.
>
> Hier bleibt eigentlich nur: Kontaktiere die Autoren der Extension und
> informiere sie.
>
>
> Viele Grüße
>
> Thomas
>
>
> Am 07.04.2017 um 10:37 schrieb Franklin Schiftan:
>> Hallo miteinander,
>>
>> ich stellte gerade unter LibO Version: 5.3.2.2
>> Build-ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
>> CPU-Threads: 8; BS-Version: Windows 6.1; UI-Render: Standard;
>> Layout-Engine: neu;
>> Gebietsschema: de-DE (de_DE); Calc: group
>>
>> beim Versuch Extensions upzudaten folgendes fest (wobei diese Fehler
>> vermutlich auch völlig unabhängig von der LibO-Version in anderen
>> Versionen des Programmes so auftauchen würden):
>>
>> 1.) DateTime2.oxt:
>>
>> Ein allgemeiner Internetehler trat auf.   [sic: ohne 'f' ! ]
>>
>> http://www.re-solutions.de/ooo/extensions/DateTime2.update.xml
>> existiert nicht.
>>
>> Das ist bedauerlich, dass hier offensichtlich die in der Extension
>> vermerkte Quell-Seite für ein Update nicht mehr existiert, zumal die
>> dann jetzt unter Github gefundene Version 2.0.4 wunderbar
>> funktioniert. Ich frage mich allerdings, wodurch der Hinweis, dass
>> es ein Update für diese Extension gibt, dann ausgelöst wurde (als
>> der Update-Hinweis kam, war noch Version 2.0.3 installiert, aber
>> wenn die Update-Quelle mit der URL so gar nicht mehr existiert...).
>>
>> Das fehlende 'f' in der ersten Meldung kann sicher noch jemand
>> ergänzen ...
>>
>>
>> 2.) HistoryMaster:
>>
>> Es ist ein Fehler aufgetreten:
>> Extra content at the end of the document
>> Line: 299
>> Column: 1845
>>
>> Keine Ahnung, welches 'document' hier gemeint ist und was ich tun
>> könnte, um dieses Problem zu beheben.
>>
>>
>> 3.) Suchen&Ersetzen-Alternative für Writer:
>>
>> Es ist ein Fehler aufgetreten:
>> Unbekannter Fehler.
>>
>> Und hier weiß man natürlich noch weniger, wo man ansetzen könnte,
>> oder hat jemand Ideen?
>>
>>
>
>


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Andreas Mantke Andreas Mantke
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

Hallo miteinander,

Am 07.04.2017 um 22:59 schrieb Gerhard Weydt:

> Hallo zusammen,
>
> der Grund für solche Fehler ist, dass eine Prüfung auf fehlende rechte
> Klammern im Basic-Code in Rel. 5.3 aktiviert wurde. Die ist in einer
> späteren Version von 5.3 inzwischen wieder stillgelegt oder verbessert
> worden (Bug 106529). Man hat die Ersteller von Extensions informiert,
> und so, wie ich es mitgekriegt habe, haben SIe genauso wie ich schnell
> eine Version ihrer Extension mit ergänzten Klammern geliefert.
> Dummerweise hat die Extensions-Website, die wohl technisch umgestellt
> wurde, ein Problem mit der Ergänzung einer neuen Version, so dass die
> neueste nicht oben, sondern unten angelegt wird und somit nicht als
> neueste angezeigt wird. Der Dienstleister soll an der Korrektur
> arbeiten, aber bisher ist die Situation unverändert.
>

zur Information: ich habe mich selbst noch einmal an das Problem gesetzt
und eine Lösung gesucht. Meine Änderung am Quellcode der Software für
die Extensions-Templates-Webseite ist seit heute im Github-Repository
und bereits in die Webseite eingespielt. Es sollte nun auch dieser
kleine Fehler behoben sein.

Viele Grüße
Andreas

--
## Infrastructure Developer LibreOffice
## Freie Office-Suite für Linux, Mac, Windows
## http://LibreOffice.org
## Support the Document Foundation (http://documentfoundation.org)
## Meine Seite: http://www.amantke.de 


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Franklin Schiftan Franklin Schiftan
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

Hallo Andreas,

am 09.04.2017 um 15:10 Uhr schrieb Andreas Mantke <[hidden email]>:

> Hallo miteinander,
>
> Am 07.04.2017 um 22:59 schrieb Gerhard Weydt:
>> Hallo zusammen,
>>
>> der Grund für solche Fehler ist, dass eine Prüfung auf fehlende rechte
>> Klammern im Basic-Code in Rel. 5.3 aktiviert wurde. Die ist in einer
>> späteren Version von 5.3 inzwischen wieder stillgelegt oder verbessert
>> worden (Bug 106529). Man hat die Ersteller von Extensions informiert,
>> und so, wie ich es mitgekriegt habe, haben SIe genauso wie ich schnell
>> eine Version ihrer Extension mit ergänzten Klammern geliefert.
>> Dummerweise hat die Extensions-Website, die wohl technisch umgestellt
>> wurde, ein Problem mit der Ergänzung einer neuen Version, so dass die
>> neueste nicht oben, sondern unten angelegt wird und somit nicht als
>> neueste angezeigt wird. Der Dienstleister soll an der Korrektur
>> arbeiten, aber bisher ist die Situation unverändert.
>>
>
> zur Information: ich habe mich selbst noch einmal an das Problem gesetzt
> und eine Lösung gesucht. Meine Änderung am Quellcode der Software für
> die Extensions-Templates-Webseite ist seit heute im Github-Repository
> und bereits in die Webseite eingespielt. Es sollte nun auch dieser
> kleine Fehler behoben sein.

Die drei in meinem Ausgangsposting zu diesem Thread beschriebenen
Extension-Update-Fehler werden dadurch aber nicht behoben, gelle?

> Andreas

--
 ..... und tschüss

               Franklin

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Gerhard Weydt Gerhard Weydt
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

Hallo Franklin,

ich würde bei den betroffenen Extensions nachschauen, ob sie seit dem
ca. 23./24.3.2017 eine neue Version bekommen haben, die dank Andreas
jetzt wieder zu finden wäre, und es mit der Version erneut probieren.
Die Extension-Entwickler, bei denen eine fehlende Klammer entdeckt
wurde, wurden angeschrieben, und sie haben, soweit ich das mitgekriegt
habe, schnell reagiert und die Klammern ergänzt, so dass auch das
Release von LibO, das das Fehlen nicht toleriert, mit dieser Version
funktioniert.
Wenn du immer noch Fehler kriegst, musst du anderweitig suchen.

Gerhard

Am 09.04.2017 um 17:54 schrieb Franklin Schiftan:

> Hallo Andreas,
>
> am 09.04.2017 um 15:10 Uhr schrieb Andreas Mantke <[hidden email]>:
>
>> Hallo miteinander,
>>
>> Am 07.04.2017 um 22:59 schrieb Gerhard Weydt:
>>> Hallo zusammen,
>>>
>>> der Grund für solche Fehler ist, dass eine Prüfung auf fehlende rechte
>>> Klammern im Basic-Code in Rel. 5.3 aktiviert wurde. Die ist in einer
>>> späteren Version von 5.3 inzwischen wieder stillgelegt oder verbessert
>>> worden (Bug 106529). Man hat die Ersteller von Extensions informiert,
>>> und so, wie ich es mitgekriegt habe, haben SIe genauso wie ich schnell
>>> eine Version ihrer Extension mit ergänzten Klammern geliefert.
>>> Dummerweise hat die Extensions-Website, die wohl technisch umgestellt
>>> wurde, ein Problem mit der Ergänzung einer neuen Version, so dass die
>>> neueste nicht oben, sondern unten angelegt wird und somit nicht als
>>> neueste angezeigt wird. Der Dienstleister soll an der Korrektur
>>> arbeiten, aber bisher ist die Situation unverändert.
>>>
>> zur Information: ich habe mich selbst noch einmal an das Problem gesetzt
>> und eine Lösung gesucht. Meine Änderung am Quellcode der Software für
>> die Extensions-Templates-Webseite ist seit heute im Github-Repository
>> und bereits in die Webseite eingespielt. Es sollte nun auch dieser
>> kleine Fehler behoben sein.
> Die drei in meinem Ausgangsposting zu diesem Thread beschriebenen
> Extension-Update-Fehler werden dadurch aber nicht behoben, gelle?
>
>> Andreas


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Dennis Roczek Dennis Roczek
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hallo *,

von den ReleaseNote 5.3:
Programmation & Support
BASIC parser will no more silently accept missing close parenthesis
(commit by Pierre Lepage, tdf#80731). Existing macros and extensions
having this erroneous syntax will not work anymore, and should be fixed
(see tdf#106529). Known problematic extensions include Read Text,
TexMaths, AltSearch.

/// wiki code start
* BASIC parser will no more silently accept missing close parenthesis
({{commit|379b7ffb68bed5bc376a91032a781be147a6eff1|commit by Pierre
Lepage}}, {{tdf|80731}}). Existing macros and extensions having this
erroneous syntax will not work anymore, and should be fixed (see
{{tdf|106529}}). Known problematic extensions include
[https://extensions.libreoffice.org/extensions/read-text Read Text],
[https://extensions.libreoffice.org/extensions/texmaths-1 TexMaths],
[https://extensions.libreoffice.org/extensions/alternative-dialog-find-r
eplace-for-writer
AltSearch].
/// wiki code ende

was wieder entfernt worden ist:
https://wiki.documentfoundation.org/index.php?title=ReleaseNotes%2F5.4&t
ype=revision&diff=145963&oldid=145578
mit der Begründung, dass das wieder rückgängig gemacht worden ist.
Einfach 5.3.2 ausprobieren (oder vl. noch ein Release warten) und alles
ist wieder gut. :-)

Gruß

Dennis


On 10.04.2017 10:23, Gerhard Weydt wrote:

> Hallo Franklin,
>
> ich würde bei den betroffenen Extensions nachschauen, ob sie seit dem
> ca. 23./24.3.2017 eine neue Version bekommen haben, die dank Andreas
> jetzt wieder zu finden wäre, und es mit der Version erneut probieren.
> Die Extension-Entwickler, bei denen eine fehlende Klammer entdeckt
> wurde, wurden angeschrieben, und sie haben, soweit ich das mitgekriegt
> habe, schnell reagiert und die Klammern ergänzt, so dass auch das
> Release von LibO, das das Fehlen nicht toleriert, mit dieser Version
> funktioniert.
> Wenn du immer noch Fehler kriegst, musst du anderweitig suchen.
>
> Gerhard
>
> Am 09.04.2017 um 17:54 schrieb Franklin Schiftan:
>> Hallo Andreas,
>>
>> am 09.04.2017 um 15:10 Uhr schrieb Andreas Mantke <[hidden email]>:
>>
>>> Hallo miteinander,
>>>
>>> Am 07.04.2017 um 22:59 schrieb Gerhard Weydt:
>>>> Hallo zusammen,
>>>>
>>>> der Grund für solche Fehler ist, dass eine Prüfung auf fehlende rec
hte
>>>> Klammern im Basic-Code in Rel. 5.3 aktiviert wurde. Die ist in eine
r
>>>> späteren Version von 5.3 inzwischen wieder stillgelegt oder verbess
ert
>>>> worden (Bug 106529). Man hat die Ersteller von Extensions informier
t,
>>>> und so, wie ich es mitgekriegt habe, haben SIe genauso wie ich schn
ell
>>>> eine Version ihrer Extension mit ergänzten Klammern geliefert.
>>>> Dummerweise hat die Extensions-Website, die wohl technisch umgestel
lt
>>>> wurde, ein Problem mit der Ergänzung einer neuen Version, so dass d
ie
>>>> neueste nicht oben, sondern unten angelegt wird und somit nicht als
>>>> neueste angezeigt wird. Der Dienstleister soll an der Korrektur
>>>> arbeiten, aber bisher ist die Situation unverändert.
>>>>
>>> zur Information: ich habe mich selbst noch einmal an das Problem ges
etzt
>>> und eine Lösung gesucht. Meine Änderung am Quellcode der Software fü
r
>>> die Extensions-Templates-Webseite ist seit heute im Github-Repositor
y
>>> und bereits in die Webseite eingespielt. Es sollte nun auch dieser
>>> kleine Fehler behoben sein.
>> Die drei in meinem Ausgangsposting zu diesem Thread beschriebenen
>> Extension-Update-Fehler werden dadurch aber nicht behoben, gelle?
>>
>>> Andreas
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJY66skAAoJEM4+Qf3OKrbZP2YQALKqGQIDOzXl2uM0yMB7UGxB
fk80qwconW/mG83Y/Ex6BzaV93VV57I4C2vTyDb0YsCZtfOpedaJ05nhWAv7zH9O
Hxf+tE77PvNnApatWq6vu78kqYfpp8HmF509Qzv/PGIPY9vfSgpbRppLdqGUKYhh
HK6aZ71wRmblHcwA6L+YJkHz03/aZFbTYBN9InQC1QWfcj9M1CXfMIpn7Hccbmpl
phfMyQ8yTxDGqzXT9JVsHvtcIxBBCRmjJdOF9R476QB36i9eoanm9BsAzyl15MW+
Ih7r5XOHWZzgvpypJ0Ep2Gpj9qBslbr3IAbPaHTLWaTXgC6cUHid/ZdDBJ7VKC9N
lnghkNuuX+U91OpM/NDDZegK2GLboctsIcovB2mU0zwKIcuohFvkBO1UC5JUSDCm
SSvfEX6BgiybsHouBOKBSg/wLCcAYngrbosVUzJJO1Um73GATQ6WlsQsHV91VBwu
M/Sp0I3MQ9wVMkDNPi7HIPGJ+UbpFmRBt44ADPmuI+zCOAPaZqZGAfNRqtVgQ+AC
jQBxpTy4fRQ/ztgLcxaJpmupWy/YFM6750qhLYh8Ep540H6DwB5vapxdzSLHpmi1
xwyKdYWOn3/rd/rdolBSrJp4via8plJoxs7yNUg26VuRYDcOWB37s19dijBsmMM4
A9Jr7quE62Y99azXmH1Y
=Uk+O
-----END PGP SIGNATURE-----

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Werner Tietz Werner Tietz
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

Hallo


Am 10.04.2017 um 17:56 schrieb Dennis Roczek:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
>
> Hallo *,
>
> von den ReleaseNote 5.3:
> Programmation & Support
> BASIC parser will no more silently accept missing close parenthesis
> (commit by Pierre Lepage, tdf#80731). Existing macros and extensions
> having this erroneous syntax will not work anymore, and should be fixed
> (see tdf#106529). Known problematic extensions include Read Text,
> TexMaths, AltSearch.
>
> /// wiki code start
> * BASIC parser will no more silently accept missing close parenthesis
> ({{commit|379b7ffb68bed5bc376a91032a781be147a6eff1|commit by Pierre
> Lepage}}, {{tdf|80731}}). Existing macros and extensions having this
> erroneous syntax will not work anymore, and should be fixed (see
> {{tdf|106529}}). Known problematic extensions include
> [https://extensions.libreoffice.org/extensions/read-text Read Text],
> [https://extensions.libreoffice.org/extensions/texmaths-1 TexMaths],
> [https://extensions.libreoffice.org/extensions/alternative-dialog-find-r
> eplace-for-writer
> AltSearch].
> /// wiki code ende
>
> was wieder entfernt worden ist:
> https://wiki.documentfoundation.org/index.php?title=ReleaseNotes%2F5.4&t
> ype=revision&diff=145963&oldid=145578
> mit der Begründung, dass das wieder rückgängig gemacht worden ist.
> Einfach 5.3.2 ausprobieren (oder vl. noch ein Release warten) und alles
> ist wieder gut. :-)
>
[OT]
Es ist schon erstaunlich, eine Änderung die __invaliden__ Basic-code
blockt, wird umgehend zurückgenommen.

Andererseits liegt
https://bugs.documentfoundation.org/show_bug.cgi?id=92007
seit beinahe 2 Jahren auf Halde, obwohl es darum geht __validen__
Python-code in der GUI ``sichtbar`` zu schalten, und darüberhinaus der
Patch für den Fehler in der Bug-meldung von mir mitgeliefert wird!
[/OT]
Werner

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Dennis Roczek Dennis Roczek
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hallo Werner,

On 11.04.2017 00:43, Werner Tietz wrote:
> Hallo
</snip>

> [OT]
> Es ist schon erstaunlich, eine Änderung die __invaliden__ Basic-code
> blockt, wird umgehend zurückgenommen.
>
> Andererseits liegt
> https://bugs.documentfoundation.org/show_bug.cgi?id=92007
> seit beinahe 2 Jahren auf Halde, obwohl es darum geht __validen__
> Python-code in der GUI ``sichtbar`` zu schalten, und darüberhinaus der
> Patch für den Fehler in der Bug-meldung von mir mitgeliefert wird!
> [/OT]
Patches gehören nach Gerrit, nicht in die Bugzilla (zumindest im
LibreOffice-Projekt).

Seies drum, ich habs mal in Gerrit reingestellt, dann wird dies auch
inenrhalb von ein paar wenigen Tagen reviewed -->
https://gerrit.libreoffice.org/#/c/36399/

Am besten bitte noch einmal das License-Statement zur Dev-ML schicken. D
anke

> Werner
Dennis
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJY7BtfAAoJEM4+Qf3OKrbZl1IP/iV5eQTDQ3kD5XWR2yUyT+2+
yExYVGlBR2wIHVMsFSnMlDkcjAkga47tOVkiL0dyaZrPc28acW7gQBL/h38HNCTP
+qSabxpUjyjst9itCHyyGKG7feu3L6qP715KaapMBoZZClIoYq1aD9TQUGFeYL5R
QyWJRWo1WWrBBZgWVavUac2pw/4m7GHFQvEcqirXZWSHQNfN1IcIwqYLwhL4vtiS
AIgeXoMpyL2Yfcfg8Gwri4EnsSk+kcyfd8NfBBTJreiT82P5VMh0EaUnTTuClzNS
0ttx7VBfp4Jbzp/Fay2K4GsOQ1INbrZeRdsNpPEGMtr4d2rrCS6RGFFIPud6nZQ0
mjdHPSZaMIngHgAfeF87aelqUPVMkWglTF8y4F1Z+sr1aLx4kKlimxYB3aPJ3bk2
QEj819U0b+8wVu6zm1+NKGGDnnBwfYA1HV81ogZVBdUxilfKWVIB2ujpJiIxSzrb
XPgS8X2aml3OsiWpCPh7hX51odKHgs1TVbM7OKlRqwVKOomSCdcE7hC+bZgpb9sb
OFaQB5s/mOSKm2YxwPfBbc3ABflz7mMbreaGbsTIy3nc8qwTlP95xeWhSCSPhhi1
/RK0ui4MWjL6wWzJPEPxirtvyY+BvH2yv77RmHLDeJjFY9UjxKTtd6SlkEUYItIh
kw/OMEy0Z6J08S2m6Dbk
=72vq
-----END PGP SIGNATURE-----

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Werner Tietz Werner Tietz
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[bug 92007] was: [de-users] Extension-Update-Fehler

Hallo Dennis

Am 11.04.2017 um 01:55 schrieb Dennis Roczek:
> Hallo Werner,
>
> On 11.04.2017 00:43, Werner Tietz wrote:

>> Andererseits liegt
>> https://bugs.documentfoundation.org/show_bug.cgi?id=92007
>> seit beinahe 2 Jahren auf Halde, obwohl es darum geht __validen__
>> Python-code in der GUI ``sichtbar`` zu schalten, und darüberhinaus der
>> Patch für den Fehler in der Bug-meldung von mir mitgeliefert wird!
>> [/OT]
> Patches gehören nach Gerrit, nicht in die Bugzilla (zumindest im
> LibreOffice-Projekt).
>
> Seies drum, ich habs mal in Gerrit reingestellt, dann wird dies auch
> inenrhalb von ein paar wenigen Tagen reviewed -->
> https://gerrit.libreoffice.org/#/c/36399/
>
> Am besten bitte noch einmal das License-Statement zur Dev-ML schicken.
> Danke

Ich bedanke mich!

Frage am Rand:
Gibts auf Gerrit keine _schlankere_ Möglichkeit um 6 Zeilen geänderten
_python_ -code einzupflegen?
Ein kompletter Build auf >200MB Quellcode scheint mir etwas overkill.





--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Dennis Roczek Dennis Roczek
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [bug 92007] was: [de-users] Extension-Update-Fehler

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hallo Werner,

On 11.04.2017 11:31, Werner Tietz wrote:

> Hallo Dennis
>
> Am 11.04.2017 um 01:55 schrieb Dennis Roczek:
>> Hallo Werner,
>>
>> On 11.04.2017 00:43, Werner Tietz wrote:
> …
>>> Andererseits liegt
>>> https://bugs.documentfoundation.org/show_bug.cgi?id=92007
>>> seit beinahe 2 Jahren auf Halde, obwohl es darum geht __validen__
>>> Python-code in der GUI ``sichtbar`` zu schalten, und darüberhinaus d
er

>>> Patch für den Fehler in der Bug-meldung von mir mitgeliefert wird!
>>> [/OT]
>> Patches gehören nach Gerrit, nicht in die Bugzilla (zumindest im
>> LibreOffice-Projekt).
>>
>> Seies drum, ich habs mal in Gerrit reingestellt, dann wird dies auch
>> inenrhalb von ein paar wenigen Tagen reviewed -->
>> https://gerrit.libreoffice.org/#/c/36399/
>>
>> Am besten bitte noch einmal das License-Statement zur Dev-ML schicken
.
>> Danke
Danke für das Licernse-Statement. Kannst du das bitte nochmal
(Entschuldigung)
senden, jedoch mit der E-Mail-Adresse aus dem Bug-Ticket?

> Ich bedanke mich!
Gern geschehen.

> Frage am Rand:
> Gibts auf Gerrit keine _schlankere_ Möglichkeit um 6 Zeilen geänderten
> _python_ -code einzupflegen?

> Ein kompletter Build auf >200MB Quellcode scheint mir etwas overkill.
Wir korrigieren hier mit hunderten Commits Quell code Kommentare
(Übersetzungen von Deutsch auf Englisch), da kommt es auf ein commit
mehr oder weniger nicht an. Keine Sorge, wir haben hier so gesehen
genügend Ressourcen. Außerdem sind dies "incrementelle" Builds, die nur
die Änderungen neu bauen.

Außerdem geht es hier nicht um das Build an sich, sondern um das
"Rechte" bzw. Reviewing handling, sodass die Commiter es einfach haben,
Änderungen geprüft einzupflegen. ;-)

Dennis
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJY7M2cAAoJEM4+Qf3OKrbZglQQAMIvmkngwGOLDfbwhFMqvMZB
2az5k6eavI7yUf1OViaQRoV33z6uKHNlvwnWc9BcnhxK7WmGSGTmzx97XoNebs4b
ivcOHKe6xy2X1GBmpZ8kIOhQnKVAR0oUJ1y/C9V8FkeLRJpZGIsjMnMhgClYfJRm
t6a44fEo5Vl39FgiFDC4QjA4SDMavpzdz1AuyElGHdYMKFYxVomQ7OpDqVMI+46K
Nq7iwIVcFdlcpLO62DTAGgACU8kg/NNdzfAbz0W5tDfAt+aSEvPDSGuABk4gEoxv
9uxIvC2DLalo9cPrwHQVfZoDONjhzLlrRlRwQGFwiJ8VC6VpB5gSjGAK6tc+txVW
kRnuF1NXIOegcj5hrfyilEHi5TksxT/eRKVnw79aqwDi1DGPedjVn4cBu8q0Vo3d
/ik9Ww80EC/YlUtIXZG+ZA5KCy6Qbnnk7e8Gqb7rfrI2pU6Z6I49pQPtKihIHjuY
DtJmq2KBj4aPst4IdlCFnLfZvgGeQoqQQV1X1FYuXUDl/lKLDIQI/q1GgemGHWhp
/lXJTXa0DHKEOgU5uENT0Pva1170EVNCSLhYpH0fE/VTa9DXuxDGMBCXCjvqZLIy
WciA22x7HxNDoFnzYpzR3IX5IJzqH1lGMtfN0UORHuhNVfzsAH2Tx0peBRS0UCo1
9FDTSF4wqjb00kXpcrR3
=sSE5
-----END PGP SIGNATURE-----

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Gerhard Weydt Gerhard Weydt
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Extension-Update-Fehler

In reply to this post by Werner Tietz
Hallo Werner,

Am 11.04.2017 um 00:43 schrieb Werner Tietz:
[alte AMils entfernt]

> [OT]
> Es ist schon erstaunlich, eine Änderung die __invaliden__ Basic-code
> blockt, wird umgehend zurückgenommen.
>
> Andererseits liegt
> https://bugs.documentfoundation.org/show_bug.cgi?id=92007
> seit beinahe 2 Jahren auf Halde, obwohl es darum geht __validen__
> Python-code in der GUI ``sichtbar`` zu schalten, und darüberhinaus der
> Patch für den Fehler in der Bug-meldung von mir mitgeliefert wird!
> [/OT]
> Werner
>
ich verstehe ja, dass du bedauerst, wenn eine Bugmeldung zwei Jahre
unbearbeitet bleibt. Ich habe auch eine, die seit einem Jahr auf
Bearbeitung wartet.
Aber die Rücknahme der strengen Prüfung auf eine fehlende rechte Klammer
ist ein anderes Kaliber. Dadurch können sehr viele Anwendungen
abbrechen, und viele Anwender können den Fehler nicht korrigieren. Stell
dir mal vor, in der Münchener Stadtverwaltung, wo das
Open-Source-Projekt wieder auf der Kippe steht, wäre der Fehler aktiv
gewesen. In der Menge Code, die da geschrieben wurde, fehlen sicher
einige rechte Klammern (ich spreche aus meiner eigenen Erfahrung: in
meiner Extension haben drei gefehlt.). Das wäre Wasser auf die Mühlen
der Open-Source-Gegner gewesen.
Zum Glück sind große Organisationen ja langsamer, und Release 5.3 sollte
derzeit in einer solchen Umgebung sowieso niemals schon produktiv gehen.
In diesem Stadium ist das Release ja gerade dazu da, solche Fehler, die
sich einschleichen oder beim Test neuer Funktionen übersehen wurden, zu
entdecken. Und dann müssen sie eben schnell wieder rausgenommen werden.
Natürlich ist eine fehlende Klammer nicht vorschriftsgemäß, aber sie
sind nun einmal vorhanden, und es ist praktisch unmöglich, sie vorab zu
korrigieren und dann ein neues Release mit strener Prüfung zu
verbreiten, weil die Sources ja verstreut bei den Anwendern liegen. Und
eine Fehleingabe stillschweigend zu korrigieren, wenn die Korrektur
unzweideutig ist, ist ja gängige Praxis. Insofern könnte man durchaus
sagen, dass der Code auch ohne die Klammer sogar valid ist.

Gruß

Gerhard

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Dennis Roczek Dennis Roczek
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [bug 92007] was: [de-users] Extension-Update-Fehler

In reply to this post by Dennis Roczek
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hallo Werner,

On 11.04.2017 14:35, Dennis Roczek wrote:

> Hallo Werner,
>
> On 11.04.2017 11:31, Werner Tietz wrote:
>> Hallo Dennis
>
>> Am 11.04.2017 um 01:55 schrieb Dennis Roczek:
>>> Hallo Werner,
>>>
>>> On 11.04.2017 00:43, Werner Tietz wrote:
>> …
>>>> Andererseits liegt
>>>> https://bugs.documentfoundation.org/show_bug.cgi?id=92007
>>>> seit beinahe 2 Jahren auf Halde, obwohl es darum geht __validen__
>>>> Python-code in der GUI ``sichtbar`` zu schalten, und darüberhinaus
d

> er
>>>> Patch für den Fehler in der Bug-meldung von mir mitgeliefert wird!
>>>> [/OT]
>>> Patches gehören nach Gerrit, nicht in die Bugzilla (zumindest im
>>> LibreOffice-Projekt).
>>>
>>> Seies drum, ich habs mal in Gerrit reingestellt, dann wird dies auch
>>> inenrhalb von ein paar wenigen Tagen reviewed -->
>>> https://gerrit.libreoffice.org/#/c/36399/
>>>
>>> Am besten bitte noch einmal das License-Statement zur Dev-ML schicke
n

> .
>>> Danke
> Danke für das Licernse-Statement. Kannst du das bitte nochmal
> (Entschuldigung)
> senden, jedoch mit der E-Mail-Adresse aus dem Bug-Ticket?
>
>> Ich bedanke mich!
> Gern geschehen.
>
>> Frage am Rand:
>> Gibts auf Gerrit keine _schlankere_ Möglichkeit um 6 Zeilen geänderte
n
>> _python_ -code einzupflegen?
>
>> Ein kompletter Build auf >200MB Quellcode scheint mir etwas overkill.
> Wir korrigieren hier mit hunderten Commits Quell code Kommentare
> (Übersetzungen von Deutsch auf Englisch), da kommt es auf ein commit
> mehr oder weniger nicht an. Keine Sorge, wir haben hier so gesehen
> genügend Ressourcen. Außerdem sind dies "incrementelle" Builds, die nu
r
> die Änderungen neu bauen.
>
> Außerdem geht es hier nicht um das Build an sich, sondern um das
> "Rechte" bzw. Reviewing handling, sodass die Commiter es einfach haben
,
> Änderungen geprüft einzupflegen. ;-)
Und schon ist dein Bugfix im Master-Quellcode. :-) So schnell kann dies
gehen,
wenn man es nach dem Prinzip macht, sodass es die Entwickler auch
"mitbekommen".

Danke. So wird dein Code-Beitrag mit der Version 5.4.0 dann endlich im
Herbst mitausgeliefert. Morgen oder Übermorgen sollte er schon in einer
"Daily"-Version drinne sein. :-)

Dennis
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJY7kv/AAoJEM4+Qf3OKrbZoPUP/3hx5mXe2lLYu8/zJOfLI26w
CQmUWkIv3bCKZurKFDCM9YxPBqrikwacRld69wXBcGhDNxeqS8D5HxWuI2h4tqRs
7HFfAY7JpV5elnq8/BzC8LJDB/6MLp4coPK8gfX3OW5lVpqemTiOGtQVvC7Xh9BN
vE/2QxBPMkx7AKK14kwt7vcELfwho+mVGuttdR9AMAw8l9ZDKPT5Rq8cgleArrHm
i22STKHNNlrm/aFfMWUbVGIBWu9kuSGTnPCKNNOyHIjkB1rRvKs59m7ZCi0U9pWx
9wfwkDlxr+yxyBr99lYZObpPawJSfxFxbUF3iM7FYe9vJMQkk68lU7X1C9MB79Y1
ZjKlYdBFMoS3Me5IOcECMV+7OZyLFD9qb0M6IWyP5/b9ofOH57JBhd1xGWu+9eU6
7ugldn8lAMj0khBYcPAbQp9eIwqz++HPj+u+SXbWKbk0W4i28DGJFVIttkn2ZQ7A
7RmgvoFou3QLbE4fpRippAV1MyiUPHBafUfbiz6eKkyIEFBD/9RyFEMpPWikbX1z
y1Vu3N8dM5ZmQGmhcSydYjXhZgvtkNafueYOS3+pIKjJQC6g45wUDoo7xE39/Y+e
R1uOq29E7Q/rCfKSkIR0JK0lCznZgNjRfGZ7jIdlqMmiMkvNPNK+OzpwXv86IOCF
SyIHEIwh1Pn3PcqPLkTc
=9QQ3
-----END PGP SIGNATURE-----

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Loading...