Impress: Crash when accessing Slide Master

classic Classic list List threaded Threaded
4 messages Options
remygauthier remygauthier
Reply | Threaded
Open this post in threaded view
|

Impress: Crash when accessing Slide Master

Hello,

Before I open a bug (I checked no one has reported something similar),
I would like to know if anyone else is experiencing the same problem I
have with Impress. These steps reproduce the problem each time:

1) Open Libre Office (version 5.3.0)
2) Select Create an Impress Presentation
3) You do not need to select a model - blank slides is fine
4) Make sure you have two slides in your presentation
5) Go to the second slide
6) Go to the Slide Transition window
7) Adjust the transition time from 2.00 sec to 1.00 sec
8) Select Dissolve
9) Then select Slide Master from the view menu

At that point I get an empty dialog with a Caution sign (exclamation
mark in a triangle) and an OK button. After pressing the OK button,
Impress crashes. These are my setup informations:

LibreOffice Information
        Version: 5.3.0.3
        Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
        CPU Threads: 4; OS Version: Linux 4.9; UI Render: default; VCL:
gtk2; Layout Engine: new;
        Downloaded from the LO site on: Feb 2, 2017 at 20:14 EST
System Information
        Manufacturer: Hewlett-Packard
        Product Name: HP ProDesk 600 G1 DM
        Intel(R) Core(TM) i5-4570T CPU @ 2.90GHz
        MemTotal: 8078900 kB
OS Information (uname -a)
        Linux 4.9.10-100.fc24.x86_64 #1 SMP Wed Feb 15 18:35:50 UTC
2017 x86_64 x86_64 x86_64 GNU/Linux

Thank you.

Rémy Gauthier.


--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
libreoffice-ml.mbourne libreoffice-ml.mbourne
Reply | Threaded
Open this post in threaded view
|

Re: Impress: Crash when accessing Slide Master

Remy Gauthier wrote:

> Hello,
>
> Before I open a bug (I checked no one has reported something similar),
> I would like to know if anyone else is experiencing the same problem I
> have with Impress. These steps reproduce the problem each time:
>
> 1) Open Libre Office (version 5.3.0)
> 2) Select Create an Impress Presentation
> 3) You do not need to select a model - blank slides is fine
> 4) Make sure you have two slides in your presentation
> 5) Go to the second slide
> 6) Go to the Slide Transition window
> 7) Adjust the transition time from 2.00 sec to 1.00 sec
> 8) Select Dissolve
> 9) Then select Slide Master from the view menu
>
> At that point I get an empty dialog with a Caution sign (exclamation
> mark in a triangle) and an OK button. After pressing the OK button,
> Impress crashes. These are my setup informations:
>
> LibreOffice Information
>         Version: 5.3.0.3
>         Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
>         CPU Threads: 4; OS Version: Linux 4.9; UI Render: default; VCL:
> gtk2; Layout Engine: new;
>         Downloaded from the LO site on: Feb 2, 2017 at 20:14 EST
> System Information
>         Manufacturer: Hewlett-Packard
>         Product Name: HP ProDesk 600 G1 DM
>         Intel(R) Core(TM) i5-4570T CPU @ 2.90GHz
>         MemTotal: 8078900 kB
> OS Information (uname -a)
>         Linux 4.9.10-100.fc24.x86_64 #1 SMP Wed Feb 15 18:35:50 UTC
> 2017 x86_64 x86_64 x86_64 GNU/Linux

Following your steps, I can reproduce with LibreOffice 5.3.0 on Windows
Vista 32-bit.

Adding a second slide and setting a transition do not seem to be
necessary - the error occurs with just the following:
1) Open LibreOffice
2) Select Create > Impress Presentation
3) Cancel the "Select a Template" dialog
4) Open the Slide Transition sidebar
5) From the menu, select View > Slide Master

An error dialog similar to that you describe appears - "LibreOffice 5.3
Fatal Error" in the title bar, an exclamation mark in a yellow triangle,
no other message, and an OK button. LibreOffice crashes after dismissing
the dialog.

LibreOffice details:
     Version: 5.3.0.3
     Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
     CPU Threads: 2; OS Version: Windows 6.0; UI Render: default; Layout
Engine: new;
     Locale: en-GB (en_GB); Calc: group

--
Mark.


--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
remygauthier remygauthier
Reply | Threaded
Open this post in threaded view
|

Re: Impress: Crash when accessing Slide Master

Thank you for the information. Bug 106266 was opened about this issue.

Rémy Gauthier.
Le mercredi 01 mars 2017 à 19:35 +0000, libreoffice-
[hidden email] a écrit :
> Remy Gauthier wrote:
> > Hello,
> >
> > > > Before I open a bug (I checked no one has reported something
similar),
> > > > I would like to know if anyone else is experiencing the same
problem I

> > have with Impress. These steps reproduce the problem each time:
> >
> > 1) Open Libre Office (version 5.3.0)
> > 2) Select Create an Impress Presentation
> > 3) You do not need to select a model - blank slides is fine
> > 4) Make sure you have two slides in your presentation
> > 5) Go to the second slide
> > 6) Go to the Slide Transition window
> > 7) Adjust the transition time from 2.00 sec to 1.00 sec
> > 8) Select Dissolve
> > 9) Then select Slide Master from the view menu
> >
> > > > At that point I get an empty dialog with a Caution sign
(exclamation
> > mark in a triangle) and an OK button. After pressing the OK button,
> > Impress crashes. These are my setup informations:
> >
> > LibreOffice Information
> >         Version: 5.3.0.3
> >         Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
> > > >         CPU Threads: 4; OS Version: Linux 4.9; UI Render: default;
VCL:

> > gtk2; Layout Engine: new;
> >         Downloaded from the LO site on: Feb 2, 2017 at 20:14 EST
> > System Information
> >         Manufacturer: Hewlett-Packard
> >         Product Name: HP ProDesk 600 G1 DM
> >         Intel(R) Core(TM) i5-4570T CPU @ 2.90GHz
> >         MemTotal: 8078900 kB
> > OS Information (uname -a)
> >         Linux 4.9.10-100.fc24.x86_64 #1 SMP Wed Feb 15 18:35:50 UTC
> > 2017 x86_64 x86_64 x86_64 GNU/Linux
>
> > Following your steps, I can reproduce with LibreOffice 5.3.0 on
Windows 

> Vista 32-bit.
>
> Adding a second slide and setting a transition do not seem to be 
> necessary - the error occurs with just the following:
> 1) Open LibreOffice
> 2) Select Create > Impress Presentation
> 3) Cancel the "Select a Template" dialog
> 4) Open the Slide Transition sidebar
> 5) From the menu, select View > Slide Master
>
> > An error dialog similar to that you describe appears - "LibreOffice
5.3 
> > Fatal Error" in the title bar, an exclamation mark in a yellow
triangle, 
> > no other message, and an OK button. LibreOffice crashes after
dismissing 
> the dialog.
>
> LibreOffice details:
>      Version: 5.3.0.3
>      Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
> >      CPU Threads: 2; OS Version: Windows 6.0; UI Render: default;
Layout 
> Engine: new;
>      Locale: en-GB (en_GB); Calc: group
>
> -- 
> Mark.
>
>

--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
libreoffice-ml.mbourne libreoffice-ml.mbourne
Reply | Threaded
Open this post in threaded view
|

Re: Impress: Crash when accessing Slide Master

At least in my case, the crash does not occur if using a new profile, so
it seems to be considered "not a bug" and closed. Shame they didn't wait
for your feedback as well. Something must have happened for the profile
to get into that state though. I've tracked the faulty line in my
profile down to one which appears to be related to sidebar state. Given
that the sidebar is relatively new, I wonder if this has resulted from a
profile created in an older version of LibreOffice not being entirely
compatible with the newer version following an upgrade...

If you have time to muck around with different versions (unfortunately I
don't at the moment), it might be worth trying to create a new profile
in an older version. I don't know whether entries in the profile are all
created on first launch, or only as first needed, so may be necessary in
that older version to go through the steps of opening the Slide
Transition sidebar and set view to slide master. Close that older
version, and then use that profile in 5.3.0 and see if the crash occurs.
If it does, I'd be inclined to report that as a bug on the basis that
the profile data isn't migrated correctly.

Mark.


Remy Gauthier wrote:

> Thank you for the information. Bug 106266 was opened about this issue.
>
> Rémy Gauthier.
> Le mercredi 01 mars 2017 à 19:35 +0000, libreoffice-
> [hidden email] a écrit :
>> Remy Gauthier wrote:
>>> Hello,
>>>
>>>>> Before I open a bug (I checked no one has reported something
> similar),
>>>>> I would like to know if anyone else is experiencing the same
> problem I
>>> have with Impress. These steps reproduce the problem each time:
>>>
>>> 1) Open Libre Office (version 5.3.0)
>>> 2) Select Create an Impress Presentation
>>> 3) You do not need to select a model - blank slides is fine
>>> 4) Make sure you have two slides in your presentation
>>> 5) Go to the second slide
>>> 6) Go to the Slide Transition window
>>> 7) Adjust the transition time from 2.00 sec to 1.00 sec
>>> 8) Select Dissolve
>>> 9) Then select Slide Master from the view menu
>>>
>>>>> At that point I get an empty dialog with a Caution sign
> (exclamation
>>> mark in a triangle) and an OK button. After pressing the OK button,
>>> Impress crashes. These are my setup informations:
>>>
>>> LibreOffice Information
>>>         Version: 5.3.0.3
>>>         Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
>>>>>         CPU Threads: 4; OS Version: Linux 4.9; UI Render: default;
> VCL:
>>> gtk2; Layout Engine: new;
>>>         Downloaded from the LO site on: Feb 2, 2017 at 20:14 EST
>>> System Information
>>>         Manufacturer: Hewlett-Packard
>>>         Product Name: HP ProDesk 600 G1 DM
>>>         Intel(R) Core(TM) i5-4570T CPU @ 2.90GHz
>>>         MemTotal: 8078900 kB
>>> OS Information (uname -a)
>>>         Linux 4.9.10-100.fc24.x86_64 #1 SMP Wed Feb 15 18:35:50 UTC
>>> 2017 x86_64 x86_64 x86_64 GNU/Linux
>>
>>> Following your steps, I can reproduce with LibreOffice 5.3.0 on
> Windows
>> Vista 32-bit.
>>
>> Adding a second slide and setting a transition do not seem to be
>> necessary - the error occurs with just the following:
>> 1) Open LibreOffice
>> 2) Select Create > Impress Presentation
>> 3) Cancel the "Select a Template" dialog
>> 4) Open the Slide Transition sidebar
>> 5) From the menu, select View > Slide Master
>>
>>> An error dialog similar to that you describe appears - "LibreOffice
> 5.3
>>> Fatal Error" in the title bar, an exclamation mark in a yellow
> triangle,
>>> no other message, and an OK button. LibreOffice crashes after
> dismissing
>> the dialog.
>>
>> LibreOffice details:
>>      Version: 5.3.0.3
>>      Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
>>>      CPU Threads: 2; OS Version: Windows 6.0; UI Render: default;
> Layout
>> Engine: new;
>>      Locale: en-GB (en_GB); Calc: group
>>
>> --
>> Mark.
>>
>>
>


--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted