LO Calc - bestimmte Werte finden und in ander Spalte einfügen

classic Classic list List threaded Threaded
3 messages Options
sk sk
Reply | Threaded
Open this post in threaded view
|

LO Calc - bestimmte Werte finden und in ander Spalte einfügen

Hallo an alle,

komme mit folgender Problemstellung nicht weiter:
Spalte A1 hat diese Werte:
*1966-01-22
*1998-05-03
geb.Mustermann
09999Musterdorf
*1955-11-12

Ich bräuchte nur die Datumswerte mit dem * davor.
Habe es mit WENN(A1 = "*";"";A1) probiert, geht aber nicht.
Auch dieser Versuch mit regEx klappt nicht:
=WENN(ZÄHLENWENN(A1;"\[*[0-9]\]");"";A1)
oder so =WENN(ZÄHLENWENN(C1;"\[^*\]");"";C1)

Gruß Peter

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
h.leininger h.leininger
Reply | Threaded
Open this post in threaded view
|

Re: LO Calc - bestimmte Werte finden und in ander Spalte einfügen

Hallo,

A1 klingt eher nach einer Zelle, nicht nach einer Spalte.

Ich habe einmal Spalte A mit 5 Zeilen probiert.

=WENN(IDENTISCH(TEIL(A1; 1; 1);"*");A1;"") (ausgedehnt  auf 5 Zeilen)
gibt mit deinem Beispiel als Ausgabe:
*1966-01-22
*1998-05-03


*1955-11-12

Gruß
Helmut

Am 05.05.2017 um 09:56 schrieb sk:

> Hallo an alle,
>
> komme mit folgender Problemstellung nicht weiter:
> Spalte A1 hat diese Werte:
> *1966-01-22
> *1998-05-03
> geb.Mustermann
> 09999Musterdorf
> *1955-11-12
>
> Ich bräuchte nur die Datumswerte mit dem * davor.
> Habe es mit WENN(A1 = "*";"";A1) probiert, geht aber nicht.
> Auch dieser Versuch mit regEx klappt nicht:
> =WENN(ZÄHLENWENN(A1;"\[*[0-9]\]");"";A1)
> oder so =WENN(ZÄHLENWENN(C1;"\[^*\]");"";C1)
>
> Gruß Peter
>


---
Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.
https://www.avast.com/antivirus



--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Helmut
Wolfgang Jäth Wolfgang Jäth
Reply | Threaded
Open this post in threaded view
|

Re: LO Calc - bestimmte Werte finden und in ander Spalte einfügen

In reply to this post by sk
Am 05.05.2017 um 09:56 schrieb sk:

>
> komme mit folgender Problemstellung nicht weiter:
> Spalte A1 hat diese Werte:
> *1966-01-22
> *1998-05-03
> geb.Mustermann
> 09999Musterdorf
> *1955-11-12
>
> Ich bräuchte nur die Datumswerte mit dem * davor.
> Habe es mit WENN(A1 = "*";"";A1) probiert, geht aber nicht.

Ja; weil "*1998-05-03" halt ungleich "*" ist. Du müsstest schon das
erste Zeichen aus den Strings extrahieren (außerdem hast du die Zweige
DANN und SONST vertauscht):

| =WENN(TEIL(A1;1;1)="*";A1;"")

> Auch dieser Versuch mit regEx klappt nicht:
> =WENN(ZÄHLENWENN(A1;"\[*[0-9]\]");"";A1)
> oder so =WENN(ZÄHLENWENN(C1;"\[^*\]");"";C1)

Was willst Du mit ZÄHLENWENN? Und das Regex-Pattern versteh ich auch
nicht (warum willst du die eckigen Klammern maskieren?).

Wenn obige simple Abfrage nicht ausreicht (Möglichkeit von False
Postives oder False Negatives), ist die Aufgabe nur über eine etwas
komplexere Kombination von Funktionen sauber zu lösen:

| =WENN(ISTFEHLER(SUCHEN("^\*\d{4}";A1));""; A1)

Gesucht wird hierbei nach dem Stern am Anfang der Zeichenfolge, gefolgt
von 4 Ziffern (bei Bedarf müsstest Du das Pattern noch weiter
spezifizieren). Wird ein Treffer gefunden, liefert die Funktion SUCHEN
dessen Startposition zurück, andernfalls einen Fehler ("#NV"). Letzteres
wird durch die äußere Funktion ISTFEHLER abgefragt. Und erst dessen
Rückgabewert kann (z. B. durch das WENN) ausgewertet werden.

Wolfgang
--

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert