LibreLogo plugin doesn't work in Mac systems

classic Classic list List threaded Threaded
6 messages Options
Andreas Formiconi Andreas Formiconi
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

LibreLogo plugin doesn't work in Mac systems

Hi,

I'm letting use hundreds of students LibreLogo extensively on their computers. No problems with Windows and most of Linux systems. However all Mac users were not able to use LibreLogo.

The commands in the menu are actually working, so that you can move the turtle and draw that way; however, as soon as you write a script and try to run it, the turtle appear but nothing happens. Apparently, nothing is executed, for instance even a print instruction is not executed.

I confirm this behavior with an old Mac hanging around in my lab: Mac OS X 10.6.8 and LibreOffice 4.3.7.2.
However, the students have a variety of configurations so that it seems a pretty general problem of the Mac implementation.

I searched these lists and other places, apparently without finding a solution.

Is there anybody having a hint?

Greetings from Florence
Andreas
anne-ology anne-ology
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: LibreLogo plugin doesn't work in Mac systems

       Not really sure what you're attempting to do with Mac,
          but having just switched to a Mac, I've found that when I open a
previous document, it opens in the Mac version.

       I'm keeping the IBM-compatible for off-line use. ;-)



From: Andreas Formiconi <[hidden email]>
Date: Sat, May 27, 2017 at 9:07 AM
Subject: [libreoffice-users] LibreLogo plugin doesn't work in Mac systems
To: [hidden email]


Hi,

I'm letting use hundreds of students LibreLogo extensively on their
computers. No problems with Windows and most of Linux systems. However all
Mac users were not able to use LibreLogo.

The commands in the menu are actually working, so that you can move the
turtle and draw that way; however, as soon as you write a script and try to
run it, the turtle appear but nothing happens. Apparently, nothing is
executed, for instance even a print instruction is not executed.

I confirm this behavior with an old Mac hanging around in my lab: Mac OS X
10.6.8 and LibreOffice 4.3.7.2.
However, the students have a variety of configurations so that it seems a
pretty general problem of the Mac implementation.

I searched these lists and other places, apparently without finding a
solution.

Is there anybody having a hint?

Greetings from Florence
Andreas

--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
toki toki
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: LibreLogo plugin doesn't work in Mac systems

In reply to this post by Andreas Formiconi
On 05/27/2017 02:07 PM, Andreas Formiconi wrote:

> However all Mac users were not able to use LibreLogo.

Is there a security setting in Mac that needs to be flipped?
Something to allow the execution of scripts within applications.

> turtle and draw that way; however, as soon as you write a script and try to
> run it, the turtle appear but nothing happens. Apparently, nothing is
> executed, for instance even a print instruction is not executed.

Can the students create macros that run, from within LibO?


Alternatively, and not recommended unless:
* You like pushing your admin skills;
* The students are currently using R;
is to configure the _use R within LibreCalc_ option, and see what
happens.(This is a third party pseudo-extension.)

jonathon

--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Andreas Formiconi Andreas Formiconi
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: LibreLogo plugin doesn't work in Mac systems

Thanks, it's a good point.

However, the students can create macros that run, from within LibO. Me too, with my Mac OS X 10.6.8 and LibreOffice 4.3.7.2 configuration. For instance I played around with /Applications/LibreOffice.app/Contents/share/Scripts/python/pythonSamples/TableSample.py and it's working fine.

I believe there is something else going on...
Alex Thurgood Alex Thurgood
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: LibreLogo plugin doesn't work in Mac systems

In reply to this post by Andreas Formiconi
Le 27/05/2017 à 16:07, Andreas Formiconi a écrit :


Hi Andreas,

> I searched these lists and other places, apparently without finding a
> solution.
>

Maybe one of the following already known bugs is relevant :

https://bugs.documentfoundation.org/buglist.cgi?quicksearch=librelogo


Alex



--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Andreas Formiconi Andreas Formiconi
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: LibreLogo plugin doesn't work in Mac systems

Oh thanks Alex,

appreciating very much, I'm going to browse those threads.

Regards
Andreas
Loading...