Navigationsproblem in Formulare - Tester gesucht

classic Classic list List threaded Threaded
14 messages Options
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Navigationsproblem in Formulare - Tester gesucht

Hallo *,

Gerhard (Weydt) hat beim Navigieren durch ein Formular festgestellt,
dass Sprünge von einem Hauptformular zu einem Unterformular und wieder
zurück häufig über die Tastatur nicht möglich sind. Daraufhin hat er ein
entsprechendes Makro für diese Funktion geschrieben. Funktioniert
zusammen mit der Tastenkombination ALT und PFEIL RECHTS. So weit, so
gut. Nur läuft bei Gerhard (Windows 10, 64bit) die Reihenfolge korrekt,
d.h. genau so, wie im Formularnavigator angezeigt. Bei mir hingegen
läuft die Reihenfolge genau anders herum: Zuerst wird das letzte
Formular angesteuert, anschließend das vorherige. Die interne
Nummerierung scheint hier vom Betriebssystem abhängig zu sein. Ich habe
hier OpenSUSE 42.2 64bit rpm Linux.

Jetzt bräuchten wir einmal Tester, die die Datei herunterladen:
http://robert.familiegrosskopf.de/lo_hb_dev/TestBaseTabFormred_o.odb

Die Datei starten, Makros erlauben.
Das Formular öffnen.
Den Cursor ganz links oben in das Feld id1 setzen.
ALT+Pfeil rechts betätigen.
Es wird eine Messagebox angezeigt, die die interne Ordnung von dem
Formular aus wiedergibt. Den Inhalt der Messagebox mit dem Bild
vergleichen, das ich als Screenshot des Formularnavigators eingefügt habe.
Die Messagebox schließen und nachsehen, in welchem Tabellenkontrollfeld
der Cursor jetzt steht.

Hier die Angaben von mir:
Messagebox
0: Formular4
1: SubForm
2: Grafisches Steuerelement 1
3: MainForm_Grid

Der Cursor spring nach Formular4 (id4)

Gruß

Robert
--
Homepage: http://robert.familiegrosskopf.de
LibreOffice Community: http://robert.familiegrosskopf.de/map_3


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Regina Henschel Regina Henschel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

Hi Robert,

ich erhalte mit Version: 5.4.0.0.alpha1+
Build ID: 8c0be54a7da6262dffe04357121814dd22b5d7fe
CPU threads: 4; OS: Windows 6.1; UI render: default;
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-15_01:35:45
Locale: de-DE (de_DE); Calc: group

0:MainForm_Grid
1:SubForm
2:Formular4
3:Grafisches Steuerelement

Der Cursor steht danach in id2.

Das Gleiche mit Version: 5.2.6.2
Build ID: a3100ed2409ebf1c212f5048fbe377c281438fdc
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default;
Locale: de-DE (de_DE); Calc: group



Mit der Version 4.1.0.0.alpha0+ (Build ID:
74f74aa5470fe631c7827897742c0ccbddcf6ad)
TinderBox: Win-x86@6, Branch:master, Time: 2013-02-23_23:21:01

erhalte ich

0:Formular4
1:Grafisches Steuerelement 1
2:MainForm_Grid
3:SubForm

Der Cursor steht danach nirgends.

Mit freundlichem Gruß
Regina





--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Alex Thurgood Alex Thurgood
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

In reply to this post by Robert Großkopf
Le 13/06/2017 à 19:52, Robert Großkopf a écrit :

Hallo Robert,

> Die Datei starten, Makros erlauben.
> Das Formular öffnen.
> Den Cursor ganz links oben in das Feld id1 setzen.
> ALT+Pfeil rechts betätigen.
> Es wird eine Messagebox angezeigt, die die interne Ordnung von dem
> Formular aus wiedergibt. Den Inhalt der Messagebox mit dem Bild
> vergleichen, das ich als Screenshot des Formularnavigators eingefügt habe.
> Die Messagebox schließen und nachsehen, in welchem Tabellenkontrollfeld
> der Cursor jetzt steht.

>
> Hier die Angaben von mir:
> Messagebox
> 0: Formular4
> 1: SubForm
> 2: Grafisches Steuerelement 1
> 3: MainForm_Grid
>

Auf meinem MacBookPro (OSX 10.12.4) mit LO 5332 :
0: Formular4
1: Grafisches Steuerelement 1
2: MainForm_Grid
3: SubForm


> Der Cursor spring nach Formular4 (id4)
>

Nach dem Schliessen, steht der Cursor immer noch im Feld ID1.


Alex




--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Thomas Hackert Thomas Hackert
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

In reply to this post by Robert Großkopf
Moin Robert, *,
sorry für die Verzögerung, aber einfach noch keine Zeit gehabt ...
:(

On Tue, Jun 13, 2017 at 07:52:24PM +0200, Robert Großkopf wrote:
<schnipp>
> Hier die Angaben von mir:
> Messagebox
> 0: Formular4
> 1: SubForm
> 2: Grafisches Steuerelement 1
> 3: MainForm_Grid

Auf Debian Testing AMD64:
0: Formular4
1: SubForm
2: Grafisches Steuerelement 1
3: MainForm_Grid

> Der Cursor spring nach Formular4 (id4)

Hier auch.

Getestet mit
Version: 5.1.6.2
Build-ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard;
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

und

Version: 5.4.0.0.beta2
Build-ID: 3cc1cdd8ee50f144e5514da51800a08119754d8f
CPU-Threads: 4; Betriebssystem:Linux 4.5; UI-Render: Standard; VCL: gtk2;
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
Bis dann
Thomas.

--
Work is of two kinds: first, altering the position of matter at or near
the earth's surface relative to other matter; second, telling other people
to do so.
                -- Bertrand Russell

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

In reply to this post by Robert Großkopf
Hallo *,

Danke für die Rückmeldungen. So wie ich das bis jetzt sehe:

Windows in den aktuellen LO-Fassungen:
Reihenfolge der internen Ordnung, die über das Makro ausgelesen wird,
entspricht der Reihenfolge, die im Formularnavigator angezeigt wird.
Der Cursor springt zum ersten Unterformular.

Linux in den aktuellen LO-Fassungen:
Reihenfolge der internen Ordnung, die über das Makro ausgelesen wird,
liest in umgekehrter Reihenfolge zuerst die Unterformulare und dann die
Felder des Formulars aus, das im Formularnavigator angezeigt wird.
Der Cursor springt so zum 2. Unterformular.

Mac in den aktuellen Fassungen:
Reihenfolge der internen Ordnung, die über das Makro ausgelesen wird,
liest ohne erkennbare Ordnung die Elemente des Formulars aus. Zuerst
erscheint das 2. Unterformular, danach die Felder des Formulars in
absteigender Reihenfolge und dann das 1. Unterformular.
Kommt noch hinzu, dass der Cursor gar nicht erst zu einem anderen
Formular springt.

Für mich kein Wunder, dass die Navigation mit der Tastatur durch
Formulare nicht funktioniert. Mit Strg + Tab sollte z.B. der Cursor aus
einem Tabellenkontrollfeld herausspringen. Tut es aber nur manchmal -
klare Ursachen sind nicht erkennbar.

Da müssen wir wohl einmal sehen, wie wir das in klare Bugmeldungen umsetzen.

Gruß

Robert
--
Homepage: http://robert.familiegrosskopf.de
LibreOffice Community: http://robert.familiegrosskopf.de/map_3


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Andreas Säger Andreas Säger
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

In reply to this post by Robert Großkopf
Am 13.06.2017 um 19:52 schrieb Robert Großkopf:
> Hallo *,
>
> Gerhard (Weydt) hat beim Navigieren durch ein Formular festgestellt,
> dass Sprünge von einem Hauptformular zu einem Unterformular und wieder
> zurück häufig über die Tastatur nicht möglich sind. Daraufhin hat er ein

Strg+Tab funktioniert bei mir immer.



--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

Hallo Andreas,
>
> Strg+Tab funktioniert bei mir immer.
>
Lade Dir doch einfach einmal die Beispieldatei runter.
http://robert.familiegrosskopf.de/lo_hb_dev/TestBaseTabFormred_o.odb
Lass Makros nicht ausführen. Starte mit dem Cursor bei ersten
Tabellenkontrollfeld. Ich komme hier mit STRG + Tab bis zum 2.
Tabellenkontrollfeld und bleibe dort hängen (keine weitere Bewegung mehr).

Ich kann gerne auch noch einfachere Formulare zur Verfügung stellen, bei
denen bei mir STRG + Tab überhaupt nichts bewirkt. In ein Subformular
komme ich auch, wenn ich im Hauptformular einzelne Felder habe und im
Subformular ein Tabellenkontrollfeld steht. Aus dem Tabellenkontrollfeld
komme ich aber selbst bei einigen einfach gestrickten Formularen aus
unerfindlichen Gründen nicht wieder raus. Siehe
http://robert.familiegrosskopf.de/lo_hb_dev/Beispiel_Sport.odb

Mit welchem System arbeitest Du, dass das beständig funktioniert? Bei
mir (OpenSUSE 42.2 64bit rpm Linux, LO 5.3.3.2) tut's das nicht.

Gruß

Robert
--
Homepage: http://robert.familiegrosskopf.de
LibreOffice Community: http://robert.familiegrosskopf.de/map_3


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Gerhard Weydt Gerhard Weydt
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

In reply to this post by Andreas Säger
Hallo Andreas, Regina, Thomas, Robert, *,

Roberts Beschreibung ist vielleicht ohne Anschauen des Makros nicht so
eindeutig: SStrg+Tab funktioniert nicht beim Spung von einem
Tabellenkontrollelement in einem Formular zu einem anderen Formular
(zumindest fast nie, ich habe einen Fall, wo das mal geht, den ich
jedoch nicht - nicht einmal im selben Dokument - reproduzieren kann). Es
funktioniert aber wohl von einem anderen Kontrollelement, also einzelnes
Feld, Auswahlliste usw. aus. Und es funktioniert auch bei
Tabellenkontrollelementen, wenn man das Formulardokument im
Bearbeitungsmodus geöffnet hat und dann dort den Designmodus
ausschaltet, aber eben nicht, wenn man das Formular direkt im
Datenverwaltungsmodus geöffnet hat. Ich will da einen Bug eröffnen.
Roberts Frage zum Testen bezieht sich auf eine verwandtes Thema, und das
Testprogramm mit dem Springen ist eigentlich nur eine bequemes Mittel,
das Phänomen zu zeigen: ich hatte versucht, den Formularwechselselbst zu
programmieren, am liebsten mit Strg+Tab, aber das funktioniert nicht,
weil erst die LibO-Funktion ausgeführt wird, z.B. von einemEinzelfeld
aus, und dann erst das Ereignis ausgelöst wird, wobei die Source
irritierenderweise *das gerade erst angesprungene
Tabellenkontrollelement* ist. Dabei haben Robert und ich entdeckt, dass
die Reihenfolge, in der die Elemente der Form durch ElementNames
geliefert werden, unterschiedlich ist, bei (meinem) Windows 10 genauso
wie im Navigator, bei Roberts Linux offenbar in umgekehrter Reihenfolge.
Ich bin jetzt - weil Regina in verschiedenen Versionen von LibO
unterschiedliche Ergebnisse hat - darauf gekommen, mal den Zugriff über
den Index auszuprobieren, was bei mir zum gleichen Verhalten führt. Um
das Programm daraufhin umzustellen, muss man nur

  * einmal in firstChild getByName(oForm.elementNames(i)) durch
    oForm.getByIndex(i) ersetzen
  * und zweimal in nextBrother getByName(oParent.ElementNames(i)) durch
    oParent.getByIndex(i)

ersetzen. Hier ist aber auch der gesamte Code zum Reinkopieren:

Sub nextForm (evt as object)

dim oCtrl as object, oForm as object, oController as object

oCtrl = evt.source.Model
oForm = oCtrl.Parent
if evt.Modifiers = com.sun.star.awt.KeyModifier.MOD2 AND evt.KeyCode =
1027 then
                                                 ' = Alt            ' =
Nach-Rechts
     oController = ThisComponent.getCurrentController()
     firstChild(oForm, oController)
end if

end sub

sub firstChild(oForm as object, oController as object)

dim i as long, elem as object

     for i = 0 to oForm.Count - 1
         elem = oForm.getByIndex(i) 'getByName(oForm.elementNames(i))
         if elem.ServiceName = "stardiv.one.form.component.Form" then
             storeTargetForm = elem.Name
             oController.getFormController(elem).activateFirst
             exit sub
         end if
     next
'        no subform found
     nextBrother(oForm, oController)

End Sub

function nextBrother(oForm as object, oController as object)
'    recursive function, looking for next brother in parent  a f t e r  
oForm

dim oParent as object, i as long, elem as object
dim formFound as boolean

     oParent = oForm.Parent
     formFound = False
     for i = 0 to oParent.Count - 1
         elem = oParent.getByIndex(i) 'getByName(oParent.ElementNames(i))
         if elem.ServiceName = "stardiv.one.form.component.Form" then
             if formFound then
                 storeTargetForm = elem.Name
                 oController.getFormController(elem).activateFirst
                 exit function
             end if
             if oForm.Name = oParent.getByIndex(i).Name then formFound =
TRUE
         end if
     next
     if oParent.ServiceName = "stardiv.one.form.component.Form" then    
'then the parent of this object is either a form or oDoc.Drawpage.Forms
         nextBrother(oParent, oController)
       else
'        msgbox "letzte Form erreicht"
         firstChild(oParent, oController)    'activate first form on
highest level
     end if

end function

Wenn Robert und Thomas das mit dem neuen Code noch mal wiederholen
(evtl. Regina mit der alten Libo-Version) und, wie ich hoffe, alle das
gleiche Ergebnis kriegen, dann wissen wir, dass auf ElementNames bzgl.
Reihenfolge kein Verlass ist, aber dass es mit dem Index wohl konsistent
auf allen BS funktioniert.

Gruß

Gerhard

Am 16.06.2017 um 16:51 schrieb Andreas Säger:

> Am 13.06.2017 um 19:52 schrieb Robert Großkopf:
>> Hallo *,
>>
>> Gerhard (Weydt) hat beim Navigieren durch ein Formular festgestellt,
>> dass Sprünge von einem Hauptformular zu einem Unterformular und wieder
>> zurück häufig über die Tastatur nicht möglich sind. Daraufhin hat er ein
> Strg+Tab funktioniert bei mir immer.
>
>
>


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Thomas Hackert Thomas Hackert
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

Moin Gerhard, *,
On Fri, Jun 16, 2017 at 10:34:06PM +0200, Gerhard Weydt wrote:
<schnipp>

> Ich bin jetzt - weil Regina in verschiedenen Versionen von LibO
> unterschiedliche Ergebnisse hat - darauf gekommen, mal den Zugriff über den
> Index auszuprobieren, was bei mir zum gleichen Verhalten führt. Um das
> Programm daraufhin umzustellen, muss man nur
>
>  * einmal in firstChild getByName(oForm.elementNames(i)) durch
>    oForm.getByIndex(i) ersetzen
>  * und zweimal in nextBrother getByName(oParent.ElementNames(i)) durch
>    oParent.getByIndex(i)
>
> ersetzen. Hier ist aber auch der gesamte Code zum Reinkopieren:

Verstehe ich das richtig, dass das bei „Tablegrids“ in „Module1 -
nextForm“ statt des ursprünglichen Basic-Codes rein muss? Da bekomme
ich ...

> Sub nextForm (evt as object)
>
> dim oCtrl as object, oForm as object, oController as object
>
> oCtrl = evt.source.Model
> oForm = oCtrl.Parent
> if evt.Modifiers = com.sun.star.awt.KeyModifier.MOD2 AND evt.KeyCode = 1027
> then

hier dann
<quote>
BASIC-Syntaxfehler.
Erwartet: Then.
</quote>
mit der 1027 markiert ... :( Aber da ich mich mit Basic gar nicht
auskenne ... :( Oder habe ich das falsche Makro bearbeitet?

Vielleicht habe ich ja auch einfach nur in 5.4.0.0beta2 einen Bug
gefunden ... ;)
Bis dann
Thomas
<Rest gelöscht>

--
Nullum magnum ingenium sine mixtura dementiae fuit.
        [There is no great genius without some touch of madness.]
                -- Seneca

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

In reply to this post by Gerhard Weydt
Hallo Gerhard,

mit dem Index erhalte ich die korrekte Reihenfolge, die auch der
Reihenfolge im Formularnavigator entspricht.

Gruß

Robert
--
Homepage: http://robert.familiegrosskopf.de
LibreOffice Community: http://robert.familiegrosskopf.de/map_3


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Andreas Säger Andreas Säger
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

In reply to this post by Robert Großkopf
Am 16.06.2017 um 19:30 schrieb Robert Großkopf:

> Hallo Andreas,
>>
>> Strg+Tab funktioniert bei mir immer.
>>
> Lade Dir doch einfach einmal die Beispieldatei runter.
> http://robert.familiegrosskopf.de/lo_hb_dev/TestBaseTabFormred_o.odb
> Lass Makros nicht ausführen. Starte mit dem Cursor bei ersten
> Tabellenkontrollfeld. Ich komme hier mit STRG + Tab bis zum 2.
> Tabellenkontrollfeld und bleibe dort hängen (keine weitere Bewegung mehr).
>

Ja, stimmt.
Der völlige Unsinn tritt ja zutage wenn man das gleiche im Testmodus
macht. Öffne das Formular zum Editieren und schalte dann den Designmodus
aus. In diesem Modus verhält sich der Tabcontroller anders als im
normalen Benutzermodus.


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

Hallo Andreas,

>>>
>>> Strg+Tab funktioniert bei mir immer.
>>>
>> Lade Dir doch einfach einmal die Beispieldatei runter.
>> http://robert.familiegrosskopf.de/lo_hb_dev/TestBaseTabFormred_o.odb
>> Lass Makros nicht ausführen. Starte mit dem Cursor bei ersten
>> Tabellenkontrollfeld. Ich komme hier mit STRG + Tab bis zum 2.
>> Tabellenkontrollfeld und bleibe dort hängen (keine weitere Bewegung mehr).
>>
>
> Ja, stimmt.
> Der völlige Unsinn tritt ja zutage wenn man das gleiche im Testmodus
> macht. Öffne das Formular zum Editieren und schalte dann den Designmodus
> aus. In diesem Modus verhält sich der Tabcontroller anders als im
> normalen Benutzermodus.
>
Ich habe daraufhin die andere Beispieldatei auch noch probiert. Das ist
genau das, was Gerhard auch schon festgestellt hat: Normales Öffnen zum
Eintragen von Daten verhält sich hier anders als das Öffnen zum
Bearbeiten und Umstellen in des Testmodus. Dort funktioniert tatsächlich
STRG + Tab in beiden Datenbanken einwandfrei.

Jetzt habe ich wenigstens schon einmal einen Ansatzpunkt für eine erste
Bugbeschreibung.

Gruß

Robert
--
Homepage: http://robert.familiegrosskopf.de
LibreOffice Community: http://robert.familiegrosskopf.de/map_3


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

Hallo *,

und hier jetzt der Bug, den ich dazu weitergegeben habe:
https://bugs.documentfoundation.org/show_bug.cgi?id=108621

Gruß

Robert
--
Homepage: http://robert.familiegrosskopf.de
LibreOffice Community: http://robert.familiegrosskopf.de/map_3


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Andreas Säger Andreas Säger
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Navigationsproblem in Formulare - Tester gesucht

Am 18.06.2017 um 18:03 schrieb Robert Großkopf:
> Hallo *,
>
> und hier jetzt der Bug, den ich dazu weitergegeben habe:
> https://bugs.documentfoundation.org/show_bug.cgi?id=108621
>
> Gruß
>
> Robert
>

Danke. Vielleicht wird das nach 12 Jahren dann doch mal ...


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Loading...