[Résolu] difference de resultat =somme()

classic Classic list List threaded Threaded
4 messages Options
Alex Alex
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Résolu] difference de resultat =somme()

This post was updated on .
bonjour
mon titre n'est peut etre pas assez explicite mais voila
j'ai un tableau:
          A
1  |  2.40
2 |  =somme(A3/1.055)    SOIT 2.61
3 | 2.75

lorsque je fais
=SOMME((A2-A1)/(A2))    le résultat retourné est 0.793 alors que google sheets me donne 0.0804
et à la main (calculatrice hein :P ) le résultat est aussi 0.0804

pourquoi donc libreoffice me donne 0.793
alors que si je fais directement =SOMME((0.21)/(A2)) le résultat est bon (0.0804)

histoire de priorité des signes ? le /1.055 semble gêné libreoffice...

merci à vous
Alex

----------------------------------------

En fait il s'agissait de la précision des calculs

les données étaient arrondies à l'affichage mais les calculs continuaient d’être faits avec la valeur précise à 4 décimales.

https://help.libreoffice.org/Calc/Using_Rounded_Off_Numbers/fr#Pour_calculer_avec_des_valeurs_arrondies_telles_qu.27affich.C3.A9es_plut.C3.B4t_que_les_valeurs_internes_exactes

Pour calculer avec des valeurs arrondies telles qu'affichées plutôt que les valeurs internes exactes

    Choisissez Outils - Options' - LibreOffice Calc'.
    Allez à la page Calcul. Cochez la case Exactitude comme affiché et quittez la boîte de dialogue en cliquant sur OK.



Merci quand même :)
Alex
Dipsode Dipsode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: difference de resultat =somme()

Bonsoir

En utilisant la calculatrice de Windows (10) et en gardant toutes les
décimales ! j'obtiens bien 0,0792727272727273 ...
A priori, c'est un problème de décimales significatives conservées ou non.
Si l'on utilise 0,206635071090048 pour A2-A1au lieu de 0.21, on obtient
bien la valeur annoncée par Calc...
Ou si l'on coche "Exactitude comme affichée" dans les options  de Calc
(Calcul) et que l'on réduit l'affichage à 2 décimales, on obtient le
même résultat que Google Sheets

D'autres part, à quoi sert d'utiliser la fonction SOMME ? Faire A3/1.055
puis (A2-A1)/A2 donne le même résultat et va plus vite ..

Bon courage

Christian Fourcroy


C

Le 17/07/2017 à 17:18, Alex a écrit :

> bonjour
> mon titre n'est peut etre pas assez explicite mais voila
> j'ai un tableau:
>            A
> 1  |  2.40
> 2 |  =somme(A3/1.055)    SOIT 2.61
> 3 | 2.75
>
> lorsque je fais
> =SOMME((A2-A1)/(A2))    le résultat retourné est 0.793 alors que google
> sheets me donne 0.0804
> et à la main (calculatrice hein :P ) le résultat est aussi 0.0804
>
> pourquoi donc libreoffice me donne 0.793
> alors que si je fais directement =SOMME((0.21)/(A2)) le résultat est bon
> (0.0804)
>
> histoire de priorité des signes ? le /1.055 semble gêné libreoffice...
>
> merci à vous
> Alex
>
>
>
> --
> View this message in context: http://nabble.documentfoundation.org/difference-de-resultat-somme-tp4218334.html
> Sent from the Users mailing list archive at Nabble.com.
>


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
LC_Libre LC_Libre
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: difference de resultat =somme()

Le 17/07/2017 à 19:51, cf a écrit :

> Bonsoir
>
> En utilisant la calculatrice de Windows (10) et en gardant toutes les
> décimales ! j'obtiens bien 0,0792727272727273 ...
> A priori, c'est un problème de décimales significatives conservées ou
> non.
> Si l'on utilise 0,206635071090048 pour A2-A1au lieu de 0.21, on
> obtient bien la valeur annoncée par Calc...
> Ou si l'on coche "Exactitude comme affichée" dans les options  de Calc
> (Calcul) et que l'on réduit l'affichage à 2 décimales, on obtient le
> même résultat que Google Sheets
>
> D'autres part, à quoi sert d'utiliser la fonction SOMME ? Faire
> A3/1.055 puis (A2-A1)/A2 donne le même résultat et va plus vite ..
>
> Bon courage
>
> Christian Fourcroy
>
>
> C
>
> Le 17/07/2017 à 17:18, Alex a écrit :
>> bonjour
>> mon titre n'est peut etre pas assez explicite mais voila
>> j'ai un tableau:
>>            A
>> 1  |  2.40
>> 2 |  =somme(A3/1.055)    SOIT 2.61
>> 3 | 2.75
>>
>> lorsque je fais
>> =SOMME((A2-A1)/(A2))    le résultat retourné est 0.793 alors que google
>> sheets me donne 0.0804
>> et à la main (calculatrice hein :P ) le résultat est aussi 0.0804
>>
>> pourquoi donc libreoffice me donne 0.793
>> alors que si je fais directement =SOMME((0.21)/(A2)) le résultat est bon
>> (0.0804)
>>
>> histoire de priorité des signes ? le /1.055 semble gêné libreoffice...
>>
>> merci à vous
>> Alex
>>
Bonjour,

j'ajoute à l'explication de Christian qu'il y a ici une confusion entre
les valeurs affichées dans Calc (ou tout autre tableur) et ce que
contiennent réellement les cellules.
Pour le dire autrement, il faut se méfier des apparences, la cellule A2
ne contient pas 2,61 ! Le résultat de l'opération ne peut pas être
réduit au nombre à 2 décimales affichées.
Saisir dans un autre système les seuls chiffres visibles à l'écran
conduit à des erreurs incompréhensibles si on ne comprend pas quelles
données on manipule.

Tout ceci pour dire que si nous comparons différents outils de calcul
–sans leur donner exactement les mêmes données– est périlleux et nous
fait imaginer des problèmes au niveau de l'outil alors qu'ils se situent
"entre la chaise et le clavier".

LC

--
Configuration : Mac OS 10.10.5, RAM 8 Gio, LibreOffice Stable 5.2.7.2 &
Évolution 5.3.4.2

--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Jean-Francois Nifenecker Jean-Francois Nifenecker
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: difference de resultat =somme()

In reply to this post by Alex
Bonjour,

Le 17/07/2017 à 17:18, Alex a écrit :

> bonjour
> mon titre n'est peut etre pas assez explicite mais voila
> j'ai un tableau:
>           A
> 1  |  2.40
> 2 |  =somme(A3/1.055)    SOIT 2.61
> 3 | 2.75
>
> lorsque je fais
> =SOMME((A2-A1)/(A2))    le résultat retourné est 0.793 alors que google
> sheets me donne 0.0804
> et à la main (calculatrice hein :P ) le résultat est aussi 0.0804
>
> pourquoi donc libreoffice me donne 0.793
> alors que si je fais directement =SOMME((0.21)/(A2)) le résultat est bon
> (0.0804)
>
> histoire de priorité des signes ? le /1.055 semble gêné libreoffice...

Euh... pourquoi diable toutes ces fonctions SOMME() qui semblent ne
servir à rien ? Votre raisonnement me semble embrouillé...

Que cherchez vous à obtenir ?


En outre, la remarque de Lutch est très pertinente : en matière de
nombres réels (nombres décimaux), attention à ce que vous voyez (la mise
en forme) et à ce avec quoi que le logiciel calcule (les nombres en
mémoire). Vous comprenez bien que la mémoire de l'ordinateur stockant
des données *binaires*, il n'est pas possible de représenter tous les
nombres réels de façon exacte. De fait des approximations sont réalisées
et vous pouvez en être la victime. Victime consentante dans la mesure où
vous ne prenez pas les précautions de rigueur (voir les fonctions
ARRONDI(), ENT() et TRONQUE()).


Si vous répondez, merci de penser à utiliser la fonction "répondre à
tous" de votre logiciel de courrier électronique de façon que la liste
reçoive une copie de votre réponse.

Bien cordialement,
--
Jean-Francois Nifenecker, Bordeaux


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Loading...