SVERWEIS

classic Classic list List threaded Threaded
6 messages Options
Boris kirkorowicz-2 Boris kirkorowicz-2
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

SVERWEIS

Hallo,
SVERWEIS() liefert bei mir stets #NV, wenn ich das Suchkriterium nicht
in doppelte Anführungszeichen einfasse. Bei festen Werten geht das (was
aber wohl nur ausnahmsweise sinnvoll sein kann), bei einem Verweis auf
eine Zelle scheitere ich jedoch:

=SVERWEIS(I5;MD;8;0)  → #NV

=SVERWEIS(1;MD;8;0)   → #NV

=SVERWEIS("1";MD;8;0) → <richtiger Wert>

(MD ist ein benannter Zellbereich)

Was kann die Ursache sein, wie kriege ich das in den Griff?



--
Mit freundlichem Gruß                                 Best regards
                            Boris Kirkorowicz

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Thomas Krumbein-3 Thomas Krumbein-3
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SVERWEIS

Hei Boris,

#NV zeigt beim sverweis an, dass der Wert nicht gefunden wurde.

Was steht denn in Celle I5?  - denn Du kannst natürlich eine Zelle als
Suchkriterium definieren.

Wenn "1" das korrekte Ergebnis liefert, schätze ich mal,  dass in Deinen
Zellen keine Zahlen (Werte) stehen sondern Texte (Strings) - dann wären
die Ergebnisse verständlich:)

Viele Grüße

Thomas


Am 21.04.2017 um 09:58 schrieb Boris Kirkorowicz:

> Hallo,
> SVERWEIS() liefert bei mir stets #NV, wenn ich das Suchkriterium nicht
> in doppelte Anführungszeichen einfasse. Bei festen Werten geht das
> (was aber wohl nur ausnahmsweise sinnvoll sein kann), bei einem
> Verweis auf eine Zelle scheitere ich jedoch:
>
> =SVERWEIS(I5;MD;8;0)  → #NV
>
> =SVERWEIS(1;MD;8;0)   → #NV
>
> =SVERWEIS("1";MD;8;0) → <richtiger Wert>
>
> (MD ist ein benannter Zellbereich)
>
> Was kann die Ursache sein, wie kriege ich das in den Griff?
>
>
>


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Werner Tietz Werner Tietz
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SVERWEIS

In reply to this post by Boris kirkorowicz-2
Hallo …

Am 21.04.2017 um 09:58 schrieb Boris Kirkorowicz:
> Hallo,
> SVERWEIS() liefert bei mir stets #NV, wenn ich das Suchkriterium nicht
> in doppelte Anführungszeichen einfasse. Bei festen Werten geht das (was
> aber wohl nur ausnahmsweise sinnvoll sein kann), bei einem Verweis auf
> eine Zelle scheitere ich jedoch:
>
> =SVERWEIS(I5;MD;8;0)  → #NV
Zelle I5 enthält die _Zahl_ 1 …

> =SVERWEIS(1;MD;8;0)   → #NV
… hier übergibst du ebenfalls die _Zahl_ 1 …
>
> =SVERWEIS("1";MD;8;0) → <richtiger Wert>
… hier übergibst du den _Text_ 1
>
> (MD ist ein benannter Zellbereich)
>
> Was kann die Ursache sein, wie kriege ich das in den Griff?

… der Bereich 'MD' enthält in der ersten Spalte keine _Zahlenwerte_
sondern _Text_

Gruß Werner



--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Fritz Szekät Fritz Szekät
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SVERWEIS

In reply to this post by Boris kirkorowicz-2
Hallo Boris,

also
1. ist die übliche Verwendung für /Suchkriterium/ ein Zellverweis also
z. B. A1, B2 etc.
2. bei mir auf Win 7 und LibO 5.2.6.2 getestet, wenn in der Suchspalte
ein Wert (Zahl) steht kann ich als valides Suchkriterium auch eine Zahl
ungequotet verwenden.

Ich vermute dein Beispiel 1 ist ein Zellverweis?
Dein Beispiel 2 ist ein Wert (Zahl) als Suchkriterium

Funktioniert bei mir unter LibO 5.2.6.2 beides mal korrekt.


Am 21.04.2017 um 09:58 schrieb Boris Kirkorowicz:

> Hallo,
> SVERWEIS() liefert bei mir stets #NV, wenn ich das Suchkriterium nicht
> in doppelte Anführungszeichen einfasse. Bei festen Werten geht das (was
> aber wohl nur ausnahmsweise sinnvoll sein kann), bei einem Verweis auf
> eine Zelle scheitere ich jedoch:
>
> =SVERWEIS(I5;MD;8;0)  → #NV
>
> =SVERWEIS(1;MD;8;0)   → #NV
>
> =SVERWEIS("1";MD;8;0) → <richtiger Wert>
>
> (MD ist ein benannter Zellbereich)
>
> Was kann die Ursache sein, wie kriege ich das in den Griff?


--
Einen schönen Tag noch
Fritz

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Fritz Szekät Fritz Szekät
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SVERWEIS

In reply to this post by Boris kirkorowicz-2
Hallo Boris,

ich denke ich weiß, wo dein Fehler liegt.

Am 21.04.2017 um 09:58 schrieb Boris Kirkorowicz:

> =SVERWEIS(I5;MD;8;0)  → #NV

In Zelle I5 steht eine Zahl in der Suchspalte ein Textstring "1"

> =SVERWEIS(1;MD;8;0)   → #NV

Siehe oben, in der Suchspalte stehen keine Werte, sondern Zeichen!

> =SVERWEIS("1";MD;8;0) → <richtiger Wert>

Weil in der Suchspalte Zeichen stehen, ein Zeichen "1", funktioniert das
Beispiel.

Also wieder der _alte_ Fehler, mischen von Datentypen.
Der Fehler sitzT zwischen Stuhllehne und Bildschirm ;-)

--
Einen schönen Tag noch
Fritz

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Boris kirkorowicz-2 Boris kirkorowicz-2
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SVERWEIS

In reply to this post by Boris kirkorowicz-2
Danke für die Hinweise; eine Umformatierung der Zelle hat Abhilfe
geschaffen.

Am 21.04.2017 um 09:58 schrieb Boris Kirkorowicz:

> Hallo,
> SVERWEIS() liefert bei mir stets #NV, wenn ich das Suchkriterium nicht
> in doppelte Anführungszeichen einfasse. Bei festen Werten geht das (was
> aber wohl nur ausnahmsweise sinnvoll sein kann), bei einem Verweis auf
> eine Zelle scheitere ich jedoch:
>
> =SVERWEIS(I5;MD;8;0)  → #NV
>
> =SVERWEIS(1;MD;8;0)   → #NV
>
> =SVERWEIS("1";MD;8;0) → <richtiger Wert>
>
> (MD ist ein benannter Zellbereich)
>
> Was kann die Ursache sein, wie kriege ich das in den Griff?


--
Mit freundlichem Gruß                                 Best regards
                            Boris Kirkorowicz

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Loading...