[it-users] Glitch grafici su calc.

classic Classic list List threaded Threaded
3 messages Options
relosrl relosrl
Reply | Threaded
Open this post in threaded view
|

[it-users] Glitch grafici su calc.

Sto testando un microcomputer con Intel® Pentium® N3710, usato come thin
client su rete ltsp. Ubuntu server 14.04 con Xenial kernel.
Ho dei problemi con calc. Solo calc, con tabelle su writer il problema
non c'è.
Anche partendo da un nuovo documento, cliccando sulle celle, dopo alcune
selezioni cominciano a comparire degli artefatti. Prima delle piccole
zone bianche che sovrastano la cella selezionata, col tempo diventano
sempre più grandi con strisce nere e rosse.
Ancora più strano, il difetto è praticamente inesistente sulle celle
vicine ad A1, più ci si allontana, più peggiora.
Ho provato ad abilitare e disabilitare l'accelerazione hardware e opengl
senza risultati.
La complessità del sistema rende difficile capire se il problema è di
Libreoffice di lstp o del driver intel. Avete mai sentito qualcosa di
simile?
Rodolfo

--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili
Mr.Crocodile Mr.Crocodile
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] Glitch grafici su calc.

Il 17/05/2017 16:33, relosrl ha scritto:

> Sto testando un microcomputer con Intel® Pentium® N3710, usato come thin
> client su rete ltsp. Ubuntu server 14.04 con Xenial kernel.
> Ho dei problemi con calc. Solo calc, con tabelle su writer il problema
> non c'è.
> Anche partendo da un nuovo documento, cliccando sulle celle, dopo alcune
> selezioni cominciano a comparire degli artefatti. Prima delle piccole
> zone bianche che sovrastano la cella selezionata, col tempo diventano
> sempre più grandi con strisce nere e rosse.
> Ancora più strano, il difetto è praticamente inesistente sulle celle
> vicine ad A1, più ci si allontana, più peggiora.
> Ho provato ad abilitare e disabilitare l'accelerazione hardware e opengl
> senza risultati.
> La complessità del sistema rende difficile capire se il problema è di
> Libreoffice di lstp o del driver intel. Avete mai sentito qualcosa di
> simile?
> Rodolfo
>
Ciao Rodolfo, ho rispolverato questa ML nella speranza di trovare
soluzione. Anche io ho notato da quando ho aggiornato alla versione
5.3.2 ( e successive) su Win7 64bit che Calc (ma ho notato che succede
anche su Writer) presenta il problema che descrivi tu. In alcune celle,
in modo piuttosto erratico, il contenuto appare barrato, alcuni
caratteri cambiano (ad esempio "asterisco" che diventa un quadratino
nero). Aggiungendo contenuto la cosa matura e cambiano di volta in volta
le celle interessate al problema. La cosa però compare anche sui menù e
sulle finestre di dialogo. Anche io ho provato ad attivare OpenGL ma
senza esito (tra l'altro nelle impostazioni alla voce Vista, nella
sezione "Risultato immagine" sotto l'opzione "Ignora lista nera OpenGL"
c'è scritto _GL è attualmente disattivato_ ma non ho idea di cosa voglia
significare; le 3 opzioni accelerazione hardware, anti-aliasing e usa
openGL sono attive).
Da dire inoltre che ho due PC con stesso sistema operativo e stessa
versione di LO. Su uno c'è il problema, sull'altro no, anche aprendo lo
stesso file. Stampando in PDF ed aprendo il PDF il problema non si vede,
il testo è esportato correttamente quindi ritengo sia un problema di
visualizzazione anche se molto fastidioso perché impedisce di leggere
correttamente il contenuto delle celle.
Infine ho appena provato a reinstallare la versione 5.2.7.2 (dopo aver
disinstallato la 5.3.3.2) e questa non è affetta da questo problema.

--
Distinti Saluti
*Andrea NARDI*

--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili
carlo.strata carlo.strata
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] Glitch grafici su calc.

Ciao a Tutti,

sarebbe bello capire, Rodolfo, quali differenze rimangono tra le
macchine uguali come versione di OS e di LibreOffice come, ad esempio,
il driver grafico (produttore, versione, 32 o 64 bit), ..., ma che
esternano comportamenti opposti.

Sarebbe interessante capire se siano ripetibili i casi solo legati al
driver grafico (posto che sia questo a differire), ma attenzione a
troppo facili deduzioni.

Ad esempio un bug segnalato da me [1] che ha, chiamiamoli così,
"disturbi grafici nella UI" sembrerebbe legato - da mie verifiche nel
vari pc di lavoro e famiglia - alle sole macchine con grafica/GPU AMD (e
forse processore/CPU AMD, non ne ho con CPU Intel e GPU AMD). Tale
problema - sullo stesso hardware e software (OS e dirver) - si presenta
solo fino alle versioni 5.2.x, ma stabilmente scompare (!!!) sin dalle
prime 5.3.x che ho testato!!!

Devo ancora segnalare questa cosa nel bug - perché l'ho appurato non da
troppo tempo e lo farò quanto prima - ma l'averlo lì pilatamente
catalogato come "NOT-OUR-BUG" forse è stato troppo azzardato e negativo
per la cura del codice stessa (QA), come peraltro forse sospetta lo
stesso Autore del commento 8, Heiko Tietze [2].

Segnalo questo perché la situazione è simile, ma con le versioni
scambiate (e forse anche le piattaforme GPU sono complementari?)... e
ciò può essere d'aiuto. Non è che per risolvere il "non nostro bug" (che
forse ed invece nostro è) si è pasticciato con i rendering della UI
sistemando una cosa e rovinandone un'altra?

È solo una mia ipotesi.

Solare fine settimana,

Carlo

p.s. Note:
[1] https://bugs.documentfoundation.org/show_bug.cgi?id=101032
[2] https://bugs.documentfoundation.org/show_bug.cgi?id=101032#c8

ing. Carlo Strata
-
via Botticelli 1/4
30031 Dolo - VE
Italia - Italy
-
tel. +39.041.822.0665
mobile +39.347.85.69.824
Skype carlo.strata
Google carlo.strata.69
-
[hidden email]
PEC: [hidden email]

Il 04/06/2017 15:58, Andrea Nardi ha scritto:

> Il 17/05/2017 16:33, relosrl ha scritto:
>> Sto testando un microcomputer con Intel® Pentium® N3710, usato come thin
>> client su rete ltsp. Ubuntu server 14.04 con Xenial kernel.
>> Ho dei problemi con calc. Solo calc, con tabelle su writer il problema
>> non c'è.
>> Anche partendo da un nuovo documento, cliccando sulle celle, dopo alcune
>> selezioni cominciano a comparire degli artefatti. Prima delle piccole
>> zone bianche che sovrastano la cella selezionata, col tempo diventano
>> sempre più grandi con strisce nere e rosse.
>> Ancora più strano, il difetto è praticamente inesistente sulle celle
>> vicine ad A1, più ci si allontana, più peggiora.
>> Ho provato ad abilitare e disabilitare l'accelerazione hardware e opengl
>> senza risultati.
>> La complessità del sistema rende difficile capire se il problema è di
>> Libreoffice di lstp o del driver intel. Avete mai sentito qualcosa di
>> simile?
>> Rodolfo
>>
> Ciao Rodolfo, ho rispolverato questa ML nella speranza di trovare
> soluzione. Anche io ho notato da quando ho aggiornato alla versione
> 5.3.2 ( e successive) su Win7 64bit che Calc (ma ho notato che succede
> anche su Writer) presenta il problema che descrivi tu. In alcune celle,
> in modo piuttosto erratico, il contenuto appare barrato, alcuni
> caratteri cambiano (ad esempio "asterisco" che diventa un quadratino
> nero). Aggiungendo contenuto la cosa matura e cambiano di volta in volta
> le celle interessate al problema. La cosa però compare anche sui menù e
> sulle finestre di dialogo. Anche io ho provato ad attivare OpenGL ma
> senza esito (tra l'altro nelle impostazioni alla voce Vista, nella
> sezione "Risultato immagine" sotto l'opzione "Ignora lista nera OpenGL"
> c'è scritto _GL è attualmente disattivato_ ma non ho idea di cosa voglia
> significare; le 3 opzioni accelerazione hardware, anti-aliasing e usa
> openGL sono attive).
> Da dire inoltre che ho due PC con stesso sistema operativo e stessa
> versione di LO. Su uno c'è il problema, sull'altro no, anche aprendo lo
> stesso file. Stampando in PDF ed aprendo il PDF il problema non si vede,
> il testo è esportato correttamente quindi ritengo sia un problema di
> visualizzazione anche se molto fastidioso perché impedisce di leggere
> correttamente il contenuto delle celle.
> Infine ho appena provato a reinstallare la versione 5.2.7.2 (dopo aver
> disinstallato la 5.3.3.2) e questa non è affetta da questo problema.
>


--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili
--
ing. Carlo Strata
-
via Botticelli 1/4
30031 Dolo - VE
Italia - Italy
-
tel./fax +39.041.822.0665
cell. +39.347.85.69.824
Skype carlo.strata
Google carlo.strata.69
-
carlo.strata@tiscali.it
PEC: carlo.strata@ingpec.eu