[it-users] verifica di casella vuota

classic Classic list List threaded Threaded
3 messages Options
Renato Pontefice Renato Pontefice
Reply | Threaded
Open this post in threaded view
|

[it-users] verifica di casella vuota

salve,
vorrei fare questa cosa, ma non so come scriverla:

se il contenuto della casella C5 è nullo, allora non faccio niente. Se è
diverso da nullo, devo mettere nella casella C3, l' orario di compilazione
della casella C5.

Come lo scrivo?

Grazie

Renato

--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili
iclam006@virgilio.it iclam006@virgilio.it
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] verifica di casella vuota

Il 27/06/2017 12:50, Renato Pontefice ha scritto:

> salve,
> vorrei fare questa cosa, ma non so come scriverla:
>
> se il contenuto della casella C5 è nullo, allora non faccio niente. Se è
> diverso da nullo, devo mettere nella casella C3, l' orario di compilazione
> della casella C5.
>
> Come lo scrivo?
>
> Grazie
>
> Renato
>
B5 deve contenere l'orario che ti serve,
nella casella C3: =SE(VAL.VUOTO(C5);"";B5)

ciao
--
Beppe

--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili
iclam006@virgilio.it iclam006@virgilio.it
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] verifica di casella vuota

In reply to this post by Renato Pontefice
Il 27/06/2017 14:29, Renato Pontefice ha scritto:

> questo, coi dovuti aggiustamenti funziona (grazie).
> Ma se io volessi che la casella C3 venisse valorizata SE e SOLO SE la
> casella C5 è valorizzara.
>
> Mi spiego ulteriormente:
> questo deve essere un registro dell chiamate telefoniche:
> Nella casella C5 metto il nome del chiamante
> vorrei che nella C3 comparisse l' orario della chiamata (che è l'
> orario dell' orologio di sistema)
>
> Come potrei fare?
>
> Renato
>
usi una macro tipo questa:

Sub TimeNow
   Dim here As Object
   here=ThisComponent.CurrentSelection
   here.setValue(Now)
   here.NumberFormat=41
End sub

crei un pulsante nuovo sulla barra standard abbini la macro e
quando sei posizionato sulla cella dove devi inserire l'orario premi il
pulsante

la funzione VAL.VUOTO() da come risposta vero o falso,
se nella casella c'e' uno spazio non la vede come vuota,
l'orario ho supposto che fosse in B5

=SE(VAL.VUOTO(C5);"";B5)

ciao
Beppe

> Il giorno mar 27 giu 2017 alle ore 14:11 [hidden email]
> <mailto:[hidden email]><[hidden email]
> <mailto:[hidden email]>> ha scritto:
>
>     Il 27/06/2017 12:50, Renato Pontefice ha scritto:
>     > salve,
>     > vorrei fare questa cosa, ma non so come scriverla:
>     >
>     > se il contenuto della casella C5 è nullo, allora non faccio
>     niente. Se è
>     > diverso da nullo, devo mettere nella casella C3, l' orario di
>     compilazione
>     > della casella C5.
>     >
>     > Come lo scrivo?
>     >
>     > Grazie
>     >
>     > Renato
>     >
>     B5 deve contenere l'orario che ti serve,
>     nella casella C3: =SE(VAL.VUOTO(C5);"";B5)
>
>     ciao
>     --
>     Beppe
>


--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili