[sv-users] Automatisera - Calc - api

classic Classic list List threaded Threaded
2 messages Options
Jan Öhman Jan Öhman
Reply | Threaded
Open this post in threaded view
|

[sv-users] Automatisera - Calc - api

Hej!

(Jag har förståelse om inte alla förstår i mitt problem och önskemål)

Håller på att skriva program som skapar dokument (främst kalkylblad med
struktur och formler)
Hittills har det gått ganska bra, (med att skapa dokument, ramar, färgad
bakgrund, fetstil, typsnitt osv.)

Men nu har jag stött på ett problem som irriterar. (förmodligen en bugg?).

För att summera innehållet i några celler i B2 kan man antingen skriva
=C4+C5+C6 eller =SUMMA(C4:C6)
i cellen B2

Så långt inga problem

Men vill jag göra samma sak i mitt nuvarande programmeringsspråk
(Autohotkey)
kan man skriva följande instruktioner .:

oCell := oSheet.getCellRangeByName("B2")
Formula := "= C4 + C5 + C6"
oCell.setFormula(Formula)
Inga problem - det fungerar som tänkt.

Testas denna kod (Svensk instruktion i Calc)
oCell := oSheet.getCellRangeByName("B2")
Formula := "= SUMMA(C4:C6)"
oCell.setFormula(Formula)
Fungerar det inte - rakt av. I cellen B2 står det "= summa(C4:C6)"
men meddelandet i cellen är "#NAMN?".
Placeras muspekaren just innan "=" i cell B2 och trycker "backspace" -
trots att jag inte kan se något tecken framför "="
Ändras innehållet i B2 till = SUMMA(C4:C6) och formeln börjar att fungera.

Testas denna kod (Engelsk instruktion i Calc)
oCell := oSheet.getCellRangeByName("B2")
Formula := "= SUM(C4:C6)"
oCell.setFormula(Formula)
Ändras innehållet i B2, automatiskt till = SUMMA(C4:C6) och formeln
fungerar utan problem.

______________________________________________

Om det varit så "enkelt" att bara använda engelska namn på instruktioner
hade det inte varit ett stort problem.
Men t.ex. instruktionen =EDATUM( "2001-03-31" ; -1) får jag inte till.
Används "backspace" före "=" visas resultatet som ett "dagvärde" och
engelska versionen =EDATE( "2001-03-31" ; -1) - fungerar inte alls.
Kanske för att datum formatet blir en krock med engelsk version?

Har inte kunnat testa dessa instruktioner i OpenOffice.

_____________________________________________


Frågor

1. Finns någon "hjälp" manual där instruktionerna anges både som Svenska
(och engelska)?

2. Kan man med någon formel byta värde på cellen (till t.ex.
datumformat)  innan instruktioner skrivs dit med ett värde?

3. Om både LibreOffice och OpenOffice är installerade på datorn, är det
svårt / mycket "knappande" att ändra standard program mellan dessa två?
(Hittas den informationen i Windows registret?)

4. (Engelska forumet lyckades jag inte logga in på längre - lite knepigt
att det ska vara så "säkert")

//Jan





--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted

Niklas Johansson Niklas Johansson
Reply | Threaded
Open this post in threaded view
|

Re: [sv-users] Automatisera - Calc - api

Hej Jan

När man använder LibreOffice API:er så är det engelska formler som gäller.
Har visserligen inte erfarenhet av just Autohotkey men principen bör vara
den samma.

Har du testat att skriva in formeln i ett kalkylblad på svenska för att
sedan ändra programspråket till engelska och öppna filen på nytt. Då borde
formeln vara på engelska. Fungerar EDATUM formeln då? Och hur ser den ut?

Det ska gå att ange regionala inställningar via API:erna men är lite osäker
på hur det skulle se ut på rak arm.

Ursäkta det allmänt hållna svaret men jag är tyvärr inte i närheten av en
dator.

/Niklas

söndag 26 juni 2016 skrev Jan Öhman <[hidden email]>:

> Hej!
>
> (Jag har förståelse om inte alla förstår i mitt problem och önskemål)
>
> Håller på att skriva program som skapar dokument (främst kalkylblad med
> struktur och formler)
> Hittills har det gått ganska bra, (med att skapa dokument, ramar, färgad
> bakgrund, fetstil, typsnitt osv.)
>
> Men nu har jag stött på ett problem som irriterar. (förmodligen en bugg?).
>
> För att summera innehållet i några celler i B2 kan man antingen skriva
> =C4+C5+C6 eller =SUMMA(C4:C6)
> i cellen B2
>
> Så långt inga problem
>
> Men vill jag göra samma sak i mitt nuvarande programmeringsspråk
> (Autohotkey)
> kan man skriva följande instruktioner .:
>
> oCell := oSheet.getCellRangeByName("B2")
> Formula := "= C4 + C5 + C6"
> oCell.setFormula(Formula)
> Inga problem - det fungerar som tänkt.
>
> Testas denna kod (Svensk instruktion i Calc)
> oCell := oSheet.getCellRangeByName("B2")
> Formula := "= SUMMA(C4:C6)"
> oCell.setFormula(Formula)
> Fungerar det inte - rakt av. I cellen B2 står det "= summa(C4:C6)"
> men meddelandet i cellen är "#NAMN?".
> Placeras muspekaren just innan "=" i cell B2 och trycker "backspace" -
> trots att jag inte kan se något tecken framför "="
> Ändras innehållet i B2 till = SUMMA(C4:C6) och formeln börjar att fungera.
>
> Testas denna kod (Engelsk instruktion i Calc)
> oCell := oSheet.getCellRangeByName("B2")
> Formula := "= SUM(C4:C6)"
> oCell.setFormula(Formula)
> Ändras innehållet i B2, automatiskt till = SUMMA(C4:C6) och formeln
> fungerar utan problem.
>
> ______________________________________________
>
> Om det varit så "enkelt" att bara använda engelska namn på instruktioner
> hade det inte varit ett stort problem.
> Men t.ex. instruktionen =EDATUM( "2001-03-31" ; -1) får jag inte till.
> Används "backspace" före "=" visas resultatet som ett "dagvärde" och
> engelska versionen =EDATE( "2001-03-31" ; -1) - fungerar inte alls.
> Kanske för att datum formatet blir en krock med engelsk version?
>
> Har inte kunnat testa dessa instruktioner i OpenOffice.
>
> _____________________________________________
>
>
> Frågor
>
> 1. Finns någon "hjälp" manual där instruktionerna anges både som Svenska
> (och engelska)?
>
> 2. Kan man med någon formel byta värde på cellen (till t.ex. datumformat)
> innan instruktioner skrivs dit med ett värde?
>
> 3. Om både LibreOffice och OpenOffice är installerade på datorn, är det
> svårt / mycket "knappande" att ändra standard program mellan dessa två?
> (Hittas den informationen i Windows registret?)
>
> 4. (Engelska forumet lyckades jag inte logga in på längre - lite knepigt
> att det ska vara så "säkert")
>
> //Jan
>
>
>
>
>
> --
> For unsubscribe instructions e-mail to:
> [hidden email]
> Problems?
> http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
> Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
> List archive: http://listarchives.libreoffice.org/sv/users/
> All messages sent to this list will be publicly archived and cannot be
> deleted
>
>

--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted