[sv-users] Calc - En Bugg? - LO 5.0.5.2?

classic Classic list List threaded Threaded
2 messages Options
Jan Öhman Jan Öhman
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[sv-users] Calc - En Bugg? - LO 5.0.5.2?

Hej!
Är detta en bugg i LibreOffice Calc v5.0.5.2?
(eller går problemet att hantera på något sätt?)

Antag följande förutsättning (Innehållet är oväsentligt)

Blad1
B10 = Dia 10
B11 = Dia 11
B12 = Dia 12
B13 = Dia 13

C10 = 10,00 kr
C11 = 20,00 kr
C12 = 30,00 kr
C13 = 40,00 kr


Blad2
B5  =OM(Blad1.B5="";"";Blad1.B5)
B6  =OM(Blad1.B6="";"";Blad1.B6)
      osv.
B20 =OM(Blad1.B20="";"";Blad1.B20)

C5 =OM(Blad1.C5="";"";Blad1.C5)
C6 =OM(Blad1.C6="";"";Blad1.C6)
      osv.
C20 =OM(Blad1.C20="";"";Blad1.C20)

D5 =OM(C5="";"";VALUTA(C5*0,8))
D6 =OM(C6="";"";VALUTA(C6*0,8))
      osv.
D20 =OM(C20="";"";VALUTA(C20*0,8))


Ändras namnet på Blad1 - inget problem.
Ändras innehåll i cellerna på Blad1, ändras innehållet i Blad2 - inget
problem.
Trycker jag "Delete" på cellen Blad1.B11, försvinner innehållet även i
Blad2.B11 - inget problem.
Kopieras innehållet i Blad1.B13 till Blad1.B7 - kopieras cellerna -
inget problem.
Så långt, inget problem.

Men...
Markeras rad 12 och jag väljer "Ta bort markerad rad" händer inget som
man ser, på Blad2. (Jag hade förväntat att något skulle inträffa på Blad2)
Trots att formlerna i Blad2 ser korrekta ut, pekar på önskad cell. Visas
inte det korrekta innehållet från Blad1.
Om absoluta värden används i cellerna - Blad2 -
ex. =OM(Blad1.$C$12="";"";VALUTA(Blad1.$C$12)) - uppstår ett
felmeddelande "#REF!"
Går detta att hantera på annat sätt? Att uppdatera Blad2 på annat sätt
än att "skriva" formlerna på nytt?
(Har OpenOffice denna begränsning?)

//Jan Ö

--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted

Jan Öhman Jan Öhman
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [sv-users] Calc - En Bugg? - LO 5.0.5.2?

Tack!

Testade i Excel 2003 och fick referensfel (#REFERENS!)
Jag förstår problemet, men ändå inte - mitt önskemål kvarstår.

Bakgrund .:
"Blad1" Kommer att innehålla "tratten" - All information som ska
bearbetas skall föras in på "Blad1"
- Importerad information
- Inknappad information
- Kopierad information
- (och kanske länkar)

"Blad1" kan innehålla allt från 10 rader till 30.000 rader.
(oftast 100-700 rader)

Denna information skall bearbetas på olika sätt.
- Rensas från konstiga tecken. - Rensa()
- Plocka bort blanksteg före och efter innehållet. - Städa()
- Valuta fält representeras oftast med decimalpunkt (men i bland även
med decimalkomma)
- Ev. gruppera med "tomma" rader eller ta bort rader.
- Utföra olika filtreringar med "autofilter" för att hitta ev. stavfel osv.

Utmaningen .:
"Blad2" (och "Blad3") vill jag ska innehålla bearbetad information från
"Blad1"
I dessa blad skall helst alla tomma rader vara borta. (om det går)
Formatera valuta och fält med önskat format. (decimaler / decimalpunkt /
decimalkomma)
Fälten ska ha en annan ordning än i "Blad1".

Ett önskemål hade varit att "Blad2" bara skulle innehålla "absoluta"
referenser.
dvs. cellen "Blad2.C235" pekar alltid på cellen "Blad1.$C$235" oavsett
om rader tillfogas eller raderas på "Blad1"
Är detta omöjligt?

Att samtidigt rensa bort alla tomma rader ser jag mer problematiskt.
Formlerna skulle nog bli ganska långa och komplicerade - tror jag.

//Jan Ö

Den 2016-04-02 kl. 12:58, skrev Johnny Rosenberg:

> Den 1 april 2016 20:38 skrev Jan Öhman <[hidden email]
> <mailto:[hidden email]>>:
>
>     Hej!
>     Är detta en bugg i LibreOffice Calc v5.0.5.2?
>     (eller går problemet att hantera på något sätt?)
>
>     Antag följande förutsättning (Innehållet är oväsentligt)
>
>     Blad1
>     B10 = Dia 10
>     B11 = Dia 11
>     B12 = Dia 12
>     B13 = Dia 13
>
>     C10 = 10,00 kr
>     C11 = 20,00 kr
>     C12 = 30,00 kr
>     C13 = 40,00 kr
>
>
>     Blad2
>     B5  =OM(Blad1.B5="";"";Blad1.B5)
>     B6  =OM(Blad1.B6="";"";Blad1.B6)
>          osv.
>     B20 =OM(Blad1.B20="";"";Blad1.B20)
>
>     C5 =OM(Blad1.C5="";"";Blad1.C5)
>     C6 =OM(Blad1.C6="";"";Blad1.C6)
>          osv.
>     C20 =OM(Blad1.C20="";"";Blad1.C20)
>
>     D5 =OM(C5="";"";VALUTA(C5*0,8))
>     D6 =OM(C6="";"";VALUTA(C6*0,8))
>          osv.
>     D20 =OM(C20="";"";VALUTA(C20*0,8))
>
>
>     Ändras namnet på Blad1 - inget problem.
>     Ändras innehåll i cellerna på Blad1, ändras innehållet i Blad2 -
>     inget problem.
>     Trycker jag "Delete" på cellen Blad1.B11, försvinner innehållet
>     även i Blad2.B11 - inget problem.
>     Kopieras innehållet i Blad1.B13 till Blad1.B7 - kopieras cellerna
>     - inget problem.
>     Så långt, inget problem.
>
>     Men...
>     Markeras rad 12 och jag väljer "Ta bort markerad rad"
>
>
> Appappappapp! Inte göra så!
>
>     händer inget som man ser, på Blad2. (Jag hade förväntat att något
>     skulle inträffa på Blad2)
>     Trots att formlerna i Blad2 ser korrekta ut, pekar på önskad cell.
>     Visas inte det korrekta innehållet från Blad1.
>     Om absoluta värden används i cellerna - Blad2 -
>     ex. =OM(Blad1.$C$12="";"";VALUTA(Blad1.$C$12)) - uppstår ett
>     felmeddelande "#REF!"
>     Går detta att hantera på annat sätt? Att uppdatera Blad2 på annat
>     sätt än att "skriva" formlerna på nytt?
>     (Har OpenOffice denna begränsning?)
>
>
> Ja, ge fan i ”Ta bort markerad rad”!
> Den förstör referenserna. Den tar ju bokstavligen bort raden, vilket
> ju naturligtvis innebär att alla celler som hänvisar till den inte
> längre vet vad de ska hänvisa till!
> Även Apache OpenOffice har denna ”begränsning”, om du nu vill kalla
> det så, då det faktiskt fungerar som det borde. Har inte testat med
> Excel, eftersom de ännu inte lyckats skrapa fram någon Linux-version,
> hur svårt det nu kan vara…
>
> Man kan säkert lösa detta på flera sätt. Själv brukar jag göra på
> följande sätt, låt oss ta ditt exempel här:
> Markera rad 13 till och med den sista raden som ska vara med plus
> ytterligare en rad (per rad du vill ”ta bort”, i detta fallet en enda).
> Ctrl+c (eller det jobbiga sättet med musen, om man nu har hela dagen
> på sig: högerklick → kopiera).
> Markera A12.
> Ctrl+v (eller, om man gillar att flytta armen mellan mus och
> tangentbord hela tiden så att man kan vara säker på att få musarm inom
> en snar framtid: högerklick → klistra in).
> Klart.
>
> Att vi markerade tomma extrarader beror ju naturligtvis på att vi
> annars skulle fått med sista raden två gånger.
> Att gå en genväg genom att istället trycka Ctrl+x utan extrarader och
> sedan placera in det hela med Ctrl+v strular också till det, så det
> verkar vara ovanstående som gäller om man vill ha koll på sina referenser.
> Har för mig att jag testat detta i Google Spreadsheet också med samma
> resultat.
>
>
> Vänliga hälsningar
>
> Johnny Rosenberg
>
>
>     //Jan Ö
>
>     --
>     For unsubscribe instructions e-mail to:
>     [hidden email]
>     <mailto:users%[hidden email]>
>     Problems?
>     http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
>     Posting guidelines + more:
>     http://wiki.documentfoundation.org/Netiquette
>     List archive: http://listarchives.libreoffice.org/sv/users/
>     All messages sent to this list will be publicly archived and
>     cannot be deleted
>
>


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted
Loading...