[sv-users] Force unique values in column - Calc

classic Classic list List threaded Threaded
5 messages Options
Joel Hallklint Joel Hallklint
Reply | Threaded
Open this post in threaded view
|

[sv-users] Force unique values in column - Calc

Hi
How kan i force a column in Calc to only accept unique values?

Regards
Joel

--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted
Jan Öhman Jan Öhman
Reply | Threaded
Open this post in threaded view
|

Re: [sv-users] Force unique values in column - Calc

You have to explain more! (Please write in Swedish in a Swedish forum)

Du måste ge en utförligare beskrivning av vad du önskar.
Spontant känns det som om du måste skriva ett skript.

//Jan

Den 2017-06-09 kl. 11:06, skrev Joel Hallklint:
> Hi
> How kan i force a column in Calc to only accept unique values?
>
> Regards
> Joel
>


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted
Joel Hallklint-2 Joel Hallklint-2
Reply | Threaded
Open this post in threaded view
|

Re: [sv-users] Force unique values in column - Calc

Hej

Jo jag jobbar med en artikellista och vill få en varning när jag försöker skriva in ett tal som redan finns i kolumnen.


Går det?


Mvh Joel


On Fri, Jun 09, 2017 at 12:14pm, Jan Öhman < [hidden email] [[hidden email]] > wrote:
You have to explain more! (Please write in Swedish in a Swedish forum)

Du måste ge en utförligare beskrivning av vad du önskar.
Spontant känns det som om du måste skriva ett skript.

//Jan

Den 2017-06-09 kl. 11:06, skrev Joel Hallklint:
> Hi
> How kan i force a column in Calc to only accept unique values?
>
> Regards
> Joel
>


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted
--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted
Jan Öhman Jan Öhman
Reply | Threaded
Open this post in threaded view
|

Re: [sv-users] Force unique values in column - Calc

Vet inte om jag fattat rätt!

Antag följande värden
B3 = 123
B4 = 234
B5 = 456
B6 = 123

Skriv följande formel i
C3 =OM(ANTAL.OM(B$3:B$10;B3)=1;"";ANTAL.OM(B$3:B$10;B3))
C4 =OM(ANTAL.OM(B$3:B$10;B4)=1;"";ANTAL.OM(B$3:B$10;B4))
C5 =OM(ANTAL.OM(B$3:B$10;B5)=1;"";ANTAL.OM(B$3:B$10;B5))
C6 =OM(ANTAL.OM(B$3:B$10;B6)=1;"";ANTAL.OM(B$3:B$10;B6))

I C3 och C6 kommer det att stå "2" övriga fält i C kolumnen kommer att
vara tomma.
Vill man trycka på resultatet ytterligare kan man skriva villkorlig en
formatering.
tex. om talet större än 1 fetoch röd stil....
osv.

//Jan


Den 2017-06-09 kl. 12:19, skrev Joel Hallklint:

>
> Hej
>
> Jo jag jobbar med en artikellista och vill få en varning när jag
> försöker skriva in ett tal som redan finns i kolumnen.
>
>
> Går det?
>
>
> Mvh Joel
>
>
> On Fri, Jun 09, 2017 at 12:14pm, Jan Öhman <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     You have to explain more! (Please write in Swedish in a Swedish forum)
>
>     Du måste ge en utförligare beskrivning av vad du önskar.
>     Spontant känns det som om du måste skriva ett skript.
>
>     //Jan
>
>     Den 2017-06-09 kl. 11:06, skrev Joel Hallklint:
>     > Hi
>     > How kan i force a column in Calc to only accept unique values?
>     >
>     > Regards
>     > Joel
>     >
>
>     --
>     For unsubscribe instructions e-mail to:
>     [hidden email]
>     Problems?
>     http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
>     Posting guidelines + more:
>     http://wiki.documentfoundation.org/Netiquette
>     List archive: http://listarchives.libreoffice.org/sv/users/
>     All messages sent to this list will be publicly archived and
>     cannot be deleted
>


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted
Jan Öhman Jan Öhman
Reply | Threaded
Open this post in threaded view
|

Re: [sv-users] Force unique values in column - Calc

Hur menar du? (ge ett exempel hur du skulle vilja se)
Att kontrollera många rader inget problem. (själv brukar jag kontrollera
20-30000rader på detta sätt.
Formeln ändras bara till
=OM(ANTAL.OM <http://ANTAL.OM>(B$3:B$2000;B3)=1;"";ANTAL.OM
<http://ANTAL.OM>(B$3:B$2000;B3)) (om man vill kontrollera cellerna
mellan 3 och 2000)
Eftersom formeln är skriven som den är skrivs formeln in i första cellen.
Sedan kopierar man den cellen till alla andra celler.
Resultatet blir att man ser alla celler med dubbletter / tripletter osv.
- antalet mer än ett visas i kolumnen bredvid den som kontrolleras

Den 2017-06-09 kl. 13:41, skrev Joel Hallklint:

> Tack
> men finns inget sätt för hela kolumnen?
>
> Detta blir svårt med 1500rader...
>
>
>
> Den 9 juni 2017 12:39 skrev Jan Öhman <[hidden email]
> <mailto:[hidden email]>>:
>
>     Vet inte om jag fattat rätt!
>
>     Antag följande värden
>     B3 = 123
>     B4 = 234
>     B5 = 456
>     B6 = 123
>
>     Skriv följande formel i
>     C3 =OM(ANTAL.OM <http://ANTAL.OM>(B$3:B$10;B3)=1;"";ANTAL.OM
>     <http://ANTAL.OM>(B$3:B$10;B3))
>     C4 =OM(ANTAL.OM <http://ANTAL.OM>(B$3:B$10;B4)=1;"";ANTAL.OM
>     <http://ANTAL.OM>(B$3:B$10;B4))
>     C5 =OM(ANTAL.OM <http://ANTAL.OM>(B$3:B$10;B5)=1;"";ANTAL.OM
>     <http://ANTAL.OM>(B$3:B$10;B5))
>     C6 =OM(ANTAL.OM <http://ANTAL.OM>(B$3:B$10;B6)=1;"";ANTAL.OM
>     <http://ANTAL.OM>(B$3:B$10;B6))
>
>     I C3 och C6 kommer det att stå "2" övriga fält i C kolumnen kommer
>     att vara tomma.
>     Vill man trycka på resultatet ytterligare kan man skriva
>     villkorlig en formatering.
>     tex. om talet större än 1 fetoch röd stil....
>     osv.
>
>     //Jan
>
>
>     Den 2017-06-09 kl. 12:19, skrev Joel Hallklint:
>
>
>         Hej
>
>         Jo jag jobbar med en artikellista och vill få en varning när
>         jag försöker skriva in ett tal som redan finns i kolumnen.
>
>
>         Går det?
>
>
>         Mvh Joel
>
>
>         On Fri, Jun 09, 2017 at 12:14pm, Jan Öhman
>         <[hidden email] <mailto:[hidden email]>
>         <mailto:[hidden email]
>         <mailto:[hidden email]>>> wrote:
>
>             You have to explain more! (Please write in Swedish in a
>         Swedish forum)
>
>             Du måste ge en utförligare beskrivning av vad du önskar.
>             Spontant känns det som om du måste skriva ett skript.
>
>             //Jan
>
>             Den 2017-06-09 kl. 11:06, skrev Joel Hallklint:
>             > Hi
>             > How kan i force a column in Calc to only accept unique
>         values?
>             >
>             > Regards
>             > Joel
>             >
>
>             --     For unsubscribe instructions e-mail to:
>         [hidden email]
>         <mailto:users%[hidden email]>
>             Problems?
>         http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
>         <http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/>
>             Posting guidelines + more:
>         http://wiki.documentfoundation.org/Netiquette
>         <http://wiki.documentfoundation.org/Netiquette>
>             List archive:
>         http://listarchives.libreoffice.org/sv/users/
>         <http://listarchives.libreoffice.org/sv/users/>
>             All messages sent to this list will be publicly archived and
>             cannot be deleted
>
>
>
>     --
>     For unsubscribe instructions e-mail to:
>     [hidden email]
>     <mailto:users%[hidden email]>
>     Problems?
>     http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
>     <http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/>
>     Posting guidelines + more:
>     http://wiki.documentfoundation.org/Netiquette
>     <http://wiki.documentfoundation.org/Netiquette>
>     List archive: http://listarchives.libreoffice.org/sv/users/
>     <http://listarchives.libreoffice.org/sv/users/>
>     All messages sent to this list will be publicly archived and
>     cannot be deleted
>
>
>
>
> --
> *´¨)
> ¸.•´¸.•*´¨) ¸.•*¨)
> (¸.•´ (¸.• Joel Hallklint



--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted