[sv-users] Knepiga beräkningar!

classic Classic list List threaded Threaded
3 messages Options
Jan Öhman Jan Öhman
Reply | Threaded
Open this post in threaded view
|

[sv-users] Knepiga beräkningar!

Hej!

Har stött på några knepiga beräkningar och stampar på en lösning som
skulle fungera.

Beskrivning / bakgrund .:
Antag att det finns tre kolumner med numeriska värden
I exemplet har jag valt samma värden och sorterade i storleksordning för
respektive grupp.
Detta för enklare kontroll, men så är det inte i verkligheten.
ex.
B3 = 123
B4 = 123
B5 = 123
B6 = 456
B7 = 789
B8 = 789

B10 = Grupp1
B11 = Grupp2
B12 = Grupp3

C3 = 1
C4 = 1
C5 = 1
C6 = 2
C7 = 3
C8 = 3

D3 = 100
D4 = 100
D5 = 100
D6 = 200
D7 = 300
D8 = 300

Första beräkningen (Löst)
Första kolumnen innehåller grupper
Grupp1 kan innehålla värden mellan 100 - 200
Grupp2 kan innehålla värden mellan 300 - 500
Grupp3 kan innehålla värden mellan 600 - 800
dvs. Resultatet blir .:
Grupp1 = 3st
Grupp2 = 1st
Grupp3 = 2st
Detta löstes genom att räkna .: "Totala antalet rader" minus "Antal
rader mindre än en grupp" minus "Antal rader större än en grupp"
(Lyckades inte använda ANTAL.OM(B3:B8; och flera villkor som OCH( >100;
<200)  )
Så långt inget problem.

Nästa beräkning är betydligt knepigare.
Här vill jag att antalet i kolumn C skall beräknas utifrån en grupp.
dvs.
I Cell C10 summera alla celler i kolumn C som tillhör Grupp1 (Facit .:
C10 = 3)
I Cell C11 summera alla celler i kolumn C som tillhör Grupp2 (Facit .:
C11 = 2)
I Cell C12 summera alla celler i kolumn C som tillhör Grupp3 (Facit .:
C12 = 6)

Samma sak gäller egentligen kolumn D
Facit .: D10 = 300
Facit .: D11 = 200
Facit .: D12 = 600

//Jan


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted

Niklas Johansson Niklas Johansson
Reply | Threaded
Open this post in threaded view
|

Re: [sv-users] Knepiga beräkningar!

Hej Jan

Jag svarar infällt i ditt meddelande nedan.

Jag ber om ursäkt att detta meddelandet blir lite långt men vill inte ta
bort sammanhanget.


On 2017-02-23 00:21, Jan Öhman wrote:

> Hej!
>
> Har stött på några knepiga beräkningar och stampar på en lösning som
> skulle fungera.
>
> Beskrivning / bakgrund .:
> Antag att det finns tre kolumner med numeriska värden
> I exemplet har jag valt samma värden och sorterade i storleksordning
> för respektive grupp.
> Detta för enklare kontroll, men så är det inte i verkligheten.
> ex.
> B3 = 123
> B4 = 123
> B5 = 123
> B6 = 456
> B7 = 789
> B8 = 789
>
> B10 = Grupp1
> B11 = Grupp2
> B12 = Grupp3
>
> C3 = 1
> C4 = 1
> C5 = 1
> C6 = 2
> C7 = 3
> C8 = 3
>
> D3 = 100
> D4 = 100
> D5 = 100
> D6 = 200
> D7 = 300
> D8 = 300
>
> Första beräkningen (Löst)
> Första kolumnen innehåller grupper
> Grupp1 kan innehålla värden mellan 100 - 200
> Grupp2 kan innehålla värden mellan 300 - 500
> Grupp3 kan innehålla värden mellan 600 - 800
> dvs. Resultatet blir .:
> Grupp1 = 3st
> Grupp2 = 1st
> Grupp3 = 2st
> Detta löstes genom att räkna .: "Totala antalet rader" minus "Antal
> rader mindre än en grupp" minus "Antal rader större än en grupp"
> (Lyckades inte använda ANTAL.OM(B3:B8; och flera villkor som OCH(
> >100; <200)  )
> Så långt inget problem.
Jag tycker du var inne på helt rätt spår. Jag skulle rekommendera att du
använder ANTAL.OMF om du ska göra flera jämförelser på detta vis.
Beräkna Grupp1 med följande formel:
=ANTAL.OMF(B3:B8;"<200";B3:B8;">100")

>
> Nästa beräkning är betydligt knepigare.
> Här vill jag att antalet i kolumn C skall beräknas utifrån en grupp.
> dvs.
> I Cell C10 summera alla celler i kolumn C som tillhör Grupp1 (Facit .:
> C10 = 3)
> I Cell C11 summera alla celler i kolumn C som tillhör Grupp2 (Facit .:
> C11 = 2)
> I Cell C12 summera alla celler i kolumn C som tillhör Grupp3 (Facit .:
> C12 = 6)
Egentligen så är det inte så knepigt som det först kan te sig. Använd
samma taktik som tidigare men nu använder du funktionen SUMMA.OMF.
Vilket ger följande formel i cellen C10.
=SUMMA.OMF(C3:C8;B3:B8;"<200";B3:B8;">100")

C11 får formeln
=SUMMA.OMF(C3:C8;B3:B8;"<500";B3:B8;">300")

C12 får formeln
=SUMMA.OMF(C3:C8;B3:B8;"<500";B3:B8;">300")

Sista delen lämnar jag som en övning till dig. Säg till om jag
missförstått något eller varit otydlig.

/Niklas
>
> Samma sak gäller egentligen kolumn D
> Facit .: D10 = 300
> Facit .: D11 = 200
> Facit .: D12 = 600
>
> //Jan
>
>


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted

Jan Öhman Jan Öhman
Reply | Threaded
Open this post in threaded view
|

Re: [sv-users] Knepiga beräkningar!

Underbart!
Tack!
Precis vad jag sökte.

(ANTAL.OMF / SUMMA.OMF) Verkligen användbara instruktioner.
På svenska verkar även dessa vara odokumenterade (gäller även ANTAL.OM)
SUMIFS och COUNTIFS verkar inte vara översatta till svenska.
COUNTIF är översatt, men inte ordet "COUNTIF :-)

Är det ett svagt stöd för den svensk översättning för LibreOffice gäller
det även OpenOffice?

//Jan

Den 2017-02-23 kl. 02:27, skrev Niklas Johansson:

> Hej Jan
>
> Jag svarar infällt i ditt meddelande nedan.
>
> Jag ber om ursäkt att detta meddelandet blir lite långt men vill inte
> ta bort sammanhanget.
>
>
> On 2017-02-23 00:21, Jan Öhman wrote:
>> Hej!
>>
>> Har stött på några knepiga beräkningar och stampar på en lösning som
>> skulle fungera.
>>
>> Beskrivning / bakgrund .:
>> Antag att det finns tre kolumner med numeriska värden
>> I exemplet har jag valt samma värden och sorterade i storleksordning
>> för respektive grupp.
>> Detta för enklare kontroll, men så är det inte i verkligheten.
>> ex.
>> B3 = 123
>> B4 = 123
>> B5 = 123
>> B6 = 456
>> B7 = 789
>> B8 = 789
>>
>> B10 = Grupp1
>> B11 = Grupp2
>> B12 = Grupp3
>>
>> C3 = 1
>> C4 = 1
>> C5 = 1
>> C6 = 2
>> C7 = 3
>> C8 = 3
>>
>> D3 = 100
>> D4 = 100
>> D5 = 100
>> D6 = 200
>> D7 = 300
>> D8 = 300
>>
>> Första beräkningen (Löst)
>> Första kolumnen innehåller grupper
>> Grupp1 kan innehålla värden mellan 100 - 200
>> Grupp2 kan innehålla värden mellan 300 - 500
>> Grupp3 kan innehålla värden mellan 600 - 800
>> dvs. Resultatet blir .:
>> Grupp1 = 3st
>> Grupp2 = 1st
>> Grupp3 = 2st
>> Detta löstes genom att räkna .: "Totala antalet rader" minus "Antal
>> rader mindre än en grupp" minus "Antal rader större än en grupp"
>> (Lyckades inte använda ANTAL.OM(B3:B8; och flera villkor som OCH(
>> >100; <200)  )
>> Så långt inget problem.
> Jag tycker du var inne på helt rätt spår. Jag skulle rekommendera att
> du använder ANTAL.OMF om du ska göra flera jämförelser på detta vis.
> Beräkna Grupp1 med följande formel:
> =ANTAL.OMF(B3:B8;"<200";B3:B8;">100")
>>
>> Nästa beräkning är betydligt knepigare.
>> Här vill jag att antalet i kolumn C skall beräknas utifrån en grupp.
>> dvs.
>> I Cell C10 summera alla celler i kolumn C som tillhör Grupp1 (Facit
>> .: C10 = 3)
>> I Cell C11 summera alla celler i kolumn C som tillhör Grupp2 (Facit
>> .: C11 = 2)
>> I Cell C12 summera alla celler i kolumn C som tillhör Grupp3 (Facit
>> .: C12 = 6)
> Egentligen så är det inte så knepigt som det först kan te sig. Använd
> samma taktik som tidigare men nu använder du funktionen SUMMA.OMF.
> Vilket ger följande formel i cellen C10.
> =SUMMA.OMF(C3:C8;B3:B8;"<200";B3:B8;">100")
>
> C11 får formeln
> =SUMMA.OMF(C3:C8;B3:B8;"<500";B3:B8;">300")
>
> C12 får formeln
> =SUMMA.OMF(C3:C8;B3:B8;"<500";B3:B8;">300")
>
> Sista delen lämnar jag som en övning till dig. Säg till om jag
> missförstått något eller varit otydlig.
>
> /Niklas
>>
>> Samma sak gäller egentligen kolumn D
>> Facit .: D10 = 300
>> Facit .: D11 = 200
>> Facit .: D12 = 600
>>
>> //Jan
>>
>>
>
>


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/sv/users/
All messages sent to this list will be publicly archived and cannot be deleted